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General Safety Summary 

Review the following safety precautions to avoid injury and prevent damage to 
this product or any products connected to it. To avoid potential hazards, use this 
product only as specified. 

Only qualified personnel should perform service procedures. 

While using this product, you may need to access other parts of the system. Read 
the General Safety Summary in other system manuals for warnings and cautions 
related to operating the system. 

To Avoid Fire or Personal Injury: 

Connect and Disconnect Properly: Do not connect or disconnect probes or test 
leads while they are connected to a voltage source. 

Observe All Terminal Ratings: To avoid fire or shock hazard, observe all 
ratings and markings on the product. Consult the product manual for further 
ratings information before making connections to the product. 

Do Not Operate With Suspected Failures: If you suspect there is damage to 
this product, have it inspected by qualified service personnel. 

Symbols and Terms: The following terms and symbols may appear in the online 
help. 

 WARNING: Warning statements identify conditions or practices that could 
result in injury or loss of life.  

 CAUTION: Caution statements identify conditions or practices that could 
result in damage to this product or other property. 

Terms on the Product: The following terms may appear on the product: 

DANGER indicates an injury hazard immediately accessible as you read the 
marking. 

WARNING indicates an injury hazard not immediately accessible as you read 
the marking. 

CAUTION indicates a hazard to property including the product. 

Symbols on the Product: The following symbol may appear in the product: 

  
CAUTION Refer to Help 
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Preface 

The TDSJIT3 v2 application consists of two products: Jitter Analysis Advanced 
and Jitter Analysis Essentials. These products are applications that enhance basic 
capabilities of some Windows-based oscilloscopes from Tektronix. These jitter 
analysis applications include the following features:  
• Select and configure multiple measurements on more than one waveform 
• Display statistical results for up to six measurements 
• Perform random and deterministic jitter analysis including BER estimation 

(TDSJIT3 v2 Advanced only) 
• Show results as plots 
• Save statistical results to a data log file 
• Save individual data points to a measurement results file 
• Save the worst case waveforms to .wfm files 

5-Time Free Trial 
A 5-time free trial is available for all applications in the "Applications on this CD 
and Compatible Oscilloscope" table found in the Optional Applications Software 
on Windows-Based Oscilloscope Installation Manual (accessible as a PDF file.) 
You can start and exit an application up to five times to help you evaluate 
Tektronix software solutions. 

If an application becomes available after you receive your oscilloscope, you can 
download the application as described in the installation manual to try the free 
trial.  

Related Documentation 
Refer to the Optional Applications Software on Windows-Based Oscilloscope 
Installation Manual for the following information: 
• Software warranty 
• List of all available applications, compatible oscilloscopes, and relevant 

software and firmware version numbers 
• Applying a new label 
• Installating an application 
• Enabling an application 
• Downloading updates from the Tektronix Web site 

Note: You can view PDF file of the installation manual from the CD Installation 
Browser and from the Documents directory on the Optional Applications 
Software on a Windows-Based Oscilloscope CD-ROM. 

GPIB Information 
For information on how to operate the oscilloscope and use the application-
specific GPIB commands, refer to the following items: 
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• The user manual for your oscilloscope provides general information on how to 
operate the oscilloscope. 

• The online help for your oscilloscope can provide details on how to use GPIB 
commands to control the oscilloscope if you install the GPIB Programmer 
guide (and code examples) from the oscilloscope CD-ROM. 

• The example directory for programming examples of how to remotely control 
the application. The default location for the example files is 
C:\TekApplications\TDSJIT3v2\Examples\GPIB-Examples. 

Relevant Web Sites 
The Tektronix Web site offers the following information: 
• Understanding and Characterizing Jitter Primer, part number 55W-16146-1  
• Jitter analysis details on the www.tektronix.com/jitter web page 

You can also find useful information in the Fibre Channel - Methodologies for 
Jitter and Signal Quality Specification – MJSQ on the www.t11.org web site. 

Application CD Contents 
The Optional Applications Software on a Windows Based Oscilloscope CD-ROM 
includes files for the following types of documentation: 
• Printable file of the TDSJIT3 v2 Jitter Analysis online help formatted to 

resemble a user manual 
• Reference guides 
• Optional Applications Installation manual 

  

Figure 1: Contents of the application CD-ROM 
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You can use the following methods to view most PDF files associated with this 
application: 
• Access a file in the Documents directory on the Optional Applications 

Software on a Windows-Based Oscilloscope CD-ROM from any PC 
• Access a file from the CD Installation Browser  
• Select a file (except Reference guides) from the Start menu in the oscilloscope 

task bar; you may need to minimize the oscilloscope and minimize the 
application  

• Use the Manuals Finder from the www.tektronix.com web site. 

You can also use this additional method to view only the PDF file of the online 
help:  
• Select the shortcut on the desktop of the oscilloscope after you minimize the 

oscilloscope 

Note: If you do not have an Acrobat reader to view a PDF file, you can get a free 
copy of the reader from the www.adobe.com/products/acrobat web page. 

Conventions 
Online help topics use the following conventions: 
• The terms "TDSJIT3 v2 application" or "application" refer to the TDSJIT3 v2 

Advanced or TDSJIT3 v2 Essentials Jitter Analysis Application (except when 
noted as Advanced only). 

• The term "oscilloscope" refers to any product on which this application runs.  
• The term "select" is a generic term that applies to the two mechanical methods 

of choosing an option: with a mouse or with the Touch Screen.  
• The term "DUT" is an abbreviation for Device Under Test.  
• User interface screen graphics are from a TDS7000 series oscilloscope; there 

may be minor differences in the displays on other types of oscilloscopes. 
• When steps require a sequence of selections using the application interface, 

the ">" delimiter marks each transition between a menu and an option. For 
example, one of the steps to recall a setup file would appear as File> Recall. 

Types of Online Help Information 
The online help contains the following types of information: 
• A Getting Started group of topics briefly describes the application, contains 

connection procedures, and includes a deskew procedure. 
• An Operating Basics group of topics covers basic operating principles of the 

application, including the Jitter Wizard. The sequence of topics reflects the 
steps you perform to operate the application and includes definitions for all 
menus and options. 

• A Tutorial group of topics teaches you how to set up the application to acquire 
a waveform, take a measurement, view the results, view a plot, and save data 
to a file. 
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• An Application Examples group of topics demonstrates how to use jitter 
measurements to identify a problem with a waveform. This should give you 
ideas on how to solve your own measurement problems. 

• A Reference group of topics specifies the minimum, maximum, incremental, 
or list of choices, and the default values for all adjustable parameters. 

• A Measurement Algorithms group of topics includes measurement guidelines 
and information on how the application calculates each measurement. 

• A GPIB Command Syntax group of topics contains a list of arguments and 
values that you can use with the remote commands and their associated 
parameters. The application includes simple remote interface programs to 
show you how to operate the application using GPIB commands. 

The application installs a desktop shortcut to access a PDF file of the help topics. 
The file is printable and is formatted to resemble a user manual. 

Using Online Help 
Online help has many advantages over a printed manual because of advanced 
search capabilities. You can select Help> Topics on the right side of the 
application menu bar to display the Help file.  

The main (opening) Help screen shows a series of book icons and three tabs 
along the top menu, each of which offers a unique mode of assistance: 
• Table of Contents (TOC) tab - organizes the Help into book-like sections. 

Select a book icon to open a section; select any of the topics listed under the 
book. 

• Index tab - enables you to scroll a list of alphabetical keywords. Select the 
topic of interest to display the corresponding help page. 

• Find tab - allows a text-based search. Follow these steps: 
1. Type the word or phrase you wish to find in the search box. 

If the word or phrase is not found, try the Index tab. 
2. Select some matching words in the next box to narrow your search. 
3. Choose a topic in the lower box, and then select the Display button. 

Note: The Find tab function does not include words found in graphics. Refer to 
the Find Tab and Searches topic for more information.  

A Note: in the topic text indicates important information.  

 When you use a mouse, you can tell when the cursor is over an active 
hyperlink because the arrow cursor changes to a small pointing hand cursor. 

The light bulb icon and word Tip in the graphic above indicates additional 
information to help you operate the application more efficiently. 

Find Tab and Searches 
Many online help topics only contain tables. To retain vertical and horizontal 
lines, the tables are graphical objects. The Find tab in the online help does not 
recognize words in these tables.  
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The online help is extensively indexed with the proper names of all menus and 
options as they appear in the application and in the left column of graphical 
tables.  

Note: If you conduct a Find tab search with no results, try the Index tab instead. 

Feedback 
Tektronix values your feedback on our products. To help us serve you better, 
please send us suggestions, ideas, or other comments you may have about your 
application or oscilloscope. 

You can email your feedback to techsupport@tektronix.com, FAX at (503) 627-
5695, or by phone. Please be as specific as possible and include the following 
information: 
General Information 

• Oscilloscope model number and hardware options, if any 
• Probes used 
• Serial data standard 
• Signaling rate 
• Your name, company, mailing address, phone number, FAX number 

Note: Please indicate if you would like to be contacted by Tektronix regarding 
your suggestion or comments. 
Application-Specific Information 

• Software version number 
• Description of the problem such that technical support can duplicate the 

problem 
• If possible, save the oscilloscope waveform file as a .wfm file 
• If possible, save the oscilloscope and application setup files from the 

application to obtain both the oscilloscope .set file and the application .ini file. 
Refer to Saving a Setup File. 

Once you have gathered this information, you can contact technical support by 
phone or through e-mail. If using e-mail, be sure to enter "TDSJIT3 v2 Problem" 
in the subject line, and attach the .set, .ini, and .wfm files. 

 To include screen shots, from the oscilloscope menu bar, select File> 
Export. In the Export dialog box, enter a file name with a .bmp extension and 
select Save. The file is saved in the C:\TekScope\Images directory. You can then 
attach the file to your email (depending on the capabilities of your email editor). 
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Getting Started 

The TDSJIT3 v2 application consists of two products: Jitter Analysis Advanced 
and Jitter Analysis Essentials. These products are applications that enhance basic 
capabilities of some Windows-based oscilloscopes from Tektronix. The 
application includes a Wizard to help you quickly set up measurements and 
obtain measurement results.  

You can use this application to do the following tasks:  
• Select and configure multiple measurements on one or more waveforms 
• Display statistical results for up to six measurements 
• Perform random and deterministic jitter analysis including BER estimation 

(TDSJIT3 v2 Advanced only) 
• Apply high pass and low pass filters to the measurements (TDSJIT3 v2 

Advanced only) 
• Display the results as Histogram, Time Trend, Cycle Trend, and Spectrum 

plots; for TDSJIT3 v2 Advanced only, also display the results as Bathtub, 
Transfer Function, and Phase Noise plots 

• Export plots  
• Log statistical results to a file 
• Log individual data points to a measurement results file 
• Log worst case waveforms to files 

Note: There are no standard accessories for this product. 

Differences between TDSJIT3 v2 Advanced and TDSJIT3 
v2 Essentials  

The TDSJIT3 v2 Advanced application provides the following features that are 
not included in the TDSJIT3 v2 Essentials application:  
• PLL-Based Clock Recovery 
• Crossover Voltage Analysis 
• Jitter separation (Rj/Dj analysis) 
• Bit error rate estimation (BER) 
• Filters 
• Bathtub, Transfer Function, and Phase Noise plots 

Features that are only available with the TDSJIT3 v2 Advanced application are 
indicated as "TDSJIT3 v2 Advanced only." 
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Compatibility 
For information on oscilloscope compatibility, refer to the product data sheet (use 
the Search tool on the www.tektronix.com web site) or the Optional Applications 
Software on Windows-Based Oscilloscopes Installation Manual, Tektronix part 
number 071-1888-XX. The manual is also available as a PDF file. 

The setup files for TDSJIT3 v2 Advanced and TDSJIT3 v2 Essentials are 
compatible with each other. 

The TDSJIT3 v2 Advanced application will recall setup files made with previous 
versions of TDSJIT3 and TDSJIT3E. To convert an existing setup file, recall it 
and then save it again. If you wish to retain a copy of the original setup file, use a 
different filename when saving. Note that setup files from previous versions may 
include directory paths such as "C:\TekApplications\TDSJIT3\...", whereas the 
v2 application defaults to "C:\TekApplications\TDSJIT3v2\...". If you would like 
your converted setup files to use the TDSJITv2 directory, recall the existing 
setup file, use the Graphical User Interface to change any file paths to use the 
new directory structure, and then save the setup. 

Requirements and Restrictions 
The Sun Java Run-Time Environment (JRE) V1.4.2 must be installed on the 
oscilloscope to operate the TDSJIT3 v2 application. When you install the 
application, the InstallShield Wizard automatically installs the proper version of 
the JRE. If the JRE is deleted, install TDSJIT3 v2 application again.  

Memory. A minimum of 512 MB PC memory is required and 1 GB PC memory 
is highly recommended.  

Keyboard. You will need to use a keyboard to enter new names for some file 
save operations. 

Accessories 
There are no standard accessories for this product. However, you can refer to the 
product datasheet available on the Tektronix Web site for information on 
optional accessories relevant to your application. 

Installation 
Refer to the Optional Applications Software on Windows-Based Oscilloscope 
Installation Manual for the following information: 
• Installing an application  

• Applying a new label  

• Enabling an application 

• Downloading updates from the Tektronix Web site 

Connecting to a Device Under Test (DUT) 

You can use any compatible probes or cable interface to connect between your 
DUT and oscilloscope. One connection is sufficient for most signals. 
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The Clock-to-Output, Skew, and Crossover Voltage (TDSJIT3 v2 Advanced 
only) measurements require two input channels, two reference, or two Math 
waveforms.  

 Warning: To avoid electric shock, remove power from the DUT before 
attaching probes. Do not touch exposed conductors except with the properly rated 
probe tips. Refer to the probe manual for proper use. 

Refer to the General Safety Summary in your oscilloscope manual. 

Deskewing Probes and Channels 

To ensure accurate results for two-channel measurements, it is important to first 
deskew the probes and oscilloscope channels before you take measurements from 
your DUT.  

The application includes an automated deskew utility that you can use to deskew 
any pair of oscilloscope channels.  

Note: To produce the best deskew results, you should connect the probes to the 
fastest signal in your DUT.  
Deskewing on Oscilloscopes with Bandwidth Extension 

Some Tektronix oscilloscopes feature software-based bandwidth extension. The 
bandwidth extension may be enabled on a per-channel basis. 

Enabling or disabling bandwidth extension on any channel affects the skew on 
that channel. Thus, you should deskew probes and channels after you make such 
configuration changes. 
Steps to Deskew Probes and Channels 

To deskew a pair of probes and oscilloscope channels, follow these steps: 
1. Refer to Connecting to a Device Under Test before starting the procedure. 
2. Connect both probes to the fastest signal in your DUT. 

Set up the oscilloscope as follows: 
1. Use the Horizontal Scale knob to set the oscilloscope to an acquisition rate so 

that there are two or more samples on the deskew edge. 
2. Use the Vertical Scale and Position knobs to adjust the signals to fill the 

display without missing any part of the signals. 
3. Set the Record Length so that there are more than 100 edges in the 

acquisition. 
4. Start the TDSJIT3 v2 application. 
5. Select Utilities> Deskew. The Deskew Utility menu appears. 
6. Set the Reference Source option to Ch1. The Source waveform is the 

reference point used to deskew the remaining channels. 
7. Set the Target Source option to Ch2. This is the channel that will be 

deskewed. 
8. To start the utility, select the Perform Deskew command button, and then 

select Yes. 
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9. Repeat steps 7 and 8 for Ch3, and then for Ch4 to deskew those channels.  
10. To view the deskew values, select the Summary button.  

  

Figure 2: Deskew complete example 

  

Figure 3:  Deskew Summary example 
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Operating Basics 

The topics in the Operating Basics book cover the following definitions and 
tasks: 
• General information, such as on navigating the user interface  
• Setting up the application  
• Taking measurements  
• Viewing the measurement results as statistics or as plots 
• Using the plot window zoom and cursors functions 
• Exporting Plot Files  
• Logging statistical results to a file  
• Logging individual data points to a file  
• Logging worst case waveforms to files  
• Saving and recalling setup files 

General Information 
Starting the TDSJIT3 v2 Application 

The way you start the application depends on the oscilloscope model. To start the 
application, do one of the following:  

• Select App > Jitter Analysis – Advanced 

• Select File > Run Application > Jitter Analysis – Advanced in the 
oscilloscope menu bar 

• Select Analyze > Jitter Analysis – Advanced 

• Select Analyze > Jitter Analysis 

If you are using the TDSJIT3 v2 Essentials application, select Jitter Analysis - 
Essentials.  
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Figure 4: Starting the TDSJIT3 v2 application 

Returning to the Application 

The way you return to the application depends on the oscilloscope model. 

  

 

Figure 5: Returning to the application 

Minimizing and Maximizing the Application 

To minimize the application, select File> Minimize or the  command button 
in the application menu bar. When you minimize the application, the oscilloscope 
fills the display. 

To maximize the application, select  in the oscilloscope task bar. 
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Exiting the Application  

To exit the application, select File> Exit or the  command button in the 
application menu bar. When you exit the application, you can choose to keep the 
oscilloscope setup currently in use with the application or to restore the 
oscilloscope setup that was present before you started the application.  

Application Directories and Usage 

During installation, the application sets up directories for various functions, such 
as to save setup files, and uses extensions appended to file names to identify the 
file types.  

Table 1: Directories and usage 

Default directory names* Directory use 
\TDSJIT3v2 Home location 
\TDSJIT3v2\Examples\GPIB-Examples Examples of remote control programs 

that use GPIB commands 
\TDSJIT3v2\Examples\waveforms Waveform files used in the tutorial 

and application examples  
\TDSJIT3v2\log Statistics log files 
\TDSJIT3v2\measurements Log files of data points for each 

selected measurement 
\TDSJIT3v2\measurementsSnapshot Measurement log files for the Save 

Current Measurements option (Log 
Measurements) 

\TDSJIT3v2\patterns Pattern files for the Advanced Clock 
Recovery configuration 

\TDSJIT3v2\plotData Data exported from measurement 
plots 

\TDSJIT3v2\plotFigures Image files exported from 
measurement plots 

\TDSJIT3v2\setup Setup files 
\TDSJIT3v2\waveforms Worst case waveforms files  
* All subdirectories are located in the C:\TekApplications directory. 
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Figure 6:  Directory structure 

Table 2: File name extensions 

Extension Description 
.bmp File that uses a “bitmap” format 
.csv File that uses a "comma separated value" format 
.ini TDSJIT3 application setup file 
.jpg File that uses a “joint photographic experts group” format  
.mat File that uses native MATLAB binary format  
.png File that uses a “portable network graphics” format 
.set Oscilloscope setup file that is recalled with an application .ini file; 

both files will have the same name 
.txt File that uses an ASCII format 
.wfm Waveform file; can be recalled into Reference memory 
  

Tips on the TDSJIT3 v2 User Interface 

Here are some tips to help you with the application user interface: 
• Use the Jitter Wizard to set up and take one measurement from a set of 

commonly used measurements 
• Select a Source before selecting each measurement 
• Select any waveform source and any measurement multiple times to use 

different configuration options 
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• Use the Single run button  to obtain a single set of measurements from 
a single run; push the button again to interrupt the acquisition 

• Use the Run/Stop button  to acquire measurements from continuous 
runs; push the button again to interrupt the current acquisition, or push the 
Single button to stop sequencing when the current acquisition and 
measurement cycle is complete 

How to Enter Numeric Values 

Table 3: Entering numeric values 

Method Description 

 Keypad Displays the virtual keypad (looks similar to a calculator); 
use to enter a value 

 Multipurpose 
    knob* 

Displays a line between the icon and the option box to 
indicate that either the upper or lower multipurpose knob 
on the front panel of the oscilloscope is active; turn the 
knob to select a value 
Press the FINE button on the oscilloscope to enter or 
select the smallest values or units 

Edit box* Type in a value from the physical keyboard and press the 
Enter key 

* When selected twice, the Keypad appears. 
  

Virtual Keypad 

Note: Select the  icon, and then use the virtual keypad to enter information, 
such as reference voltage levels. 

  

Figure 7: On-screen keypad 
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Using Basic Oscilloscope Functions 

You can use oscilloscope controls and functions while the application is running. 
To do so, select a menu from the oscilloscope Menu bar (or Toolbar) and access 
menus, or use the front-panel knobs and buttons. You can also use the 
oscilloscope Help menu to access information about the oscilloscope and how to 
use it. 

When you access some oscilloscope controls, the oscilloscope fills the display. 

File Menus 

You can use the File menus to save and recall different application setups and 
recently accessed files.  

Do not edit a setup file or recall a file not generated by the application. 

Table 4: File menus 

Menu/function Description or function 
Default Setup Recalls most default (startup) parameters 
Recall* Browse to select an application setup (.ini) file to recall; 

restores the application to the values saved in the setup file 
Save* Saves the current application settings in a .ini file 
Recent Files Select from a list of the four most recently accessed setup 

files (saved or recalled) and recall that setup 
Dock Positions and locks the TDSJIT3 v2 application in the lower 

half of the oscilloscope display and the oscilloscope 
application in the upper half of the display  

Undock Unlocks and allows you to move the TDSJIT3 v2 application 
to another position in the oscilloscope display or to a second 
monitor; the oscilloscope display returns to full size 

Minimize Minimizes the application 
Exit Exits the application; you can choose to retain the current 

oscilloscope settings or restore the oscilloscope to settings 
prior to starting the application 

*Save or Recall functions also save or recall the associated oscilloscope setup 
file (.set); an oscilloscope file is recalled if the application finds a .set file with a 
matching name. 
  

Navigating the User Interface 
The application provides you with several methods to set up the application: 
• The Jitter Wizard  
• The Measurement Setup Sequence buttons 
• The menus available in the menu bar 
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The Jitter Wizard allows you to set up, configure, and launch a single 
measurement without requiring any knowledge of the control menus. However, it 
does not provide access to many of the advanced features. 

The Measurement Setup Sequence buttons show the logical order you would 
follow to set up the application if you do not use the Jitter Wizard.  

The menus from the menu bar allow the same full control as the Measurement 
Setup Sequence buttons, but are accessible at all times.  

General Steps to Set Up the Application 

  

Figure 8:  General steps to set up the application 

Jitter Wizard 

The Jitter Wizard provides a quick and easy graphical interface that guides you 
through a short series of menus so you can take measurements in the fewest steps 
possible. The wizard lets you pick one measurement from a subset of 
measurements, and then take a single measurement only. (The application can 
take six measurements simultaneously.)  

The selections you make in each wizard menu determine the subsequent choices 
the wizard offers in the next selection menu. You can use several methods to 
configure the wizard: by preference selections, by default selections, or a 
combination of both. 

Note: You can set the Jitter Wizard menu to always appear when you start the 
application. 

To quickly take measurements, follow these steps: 
1. Select Measurements> Wizard or select Help> Wizard to launch the Jitter 

Wizard. 
2. Select a measurement category. 

3. Select the  button in each subsequent menu to use all the 
default settings.  
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4. Select the  button.  
The wizard closes, the application takes the measurement, and displays 
statistical results. 

Note: The statistical results when you use the wizard are identical to the results 
when you do not use the wizard if the measurement and setup are the same. 

When you are through setting up a measurement and plots with the wizard, select 
the Run button. The application takes the measurement and displays the results, 

including selected plots. To obtain new measurement results, select the  
Single Run button. 

If you select the Cancel button, the wizard exits and discards all of the selections.  

Note: After you use the wizard, you may decide to refine some options, such as 
the calculated values for reference voltage levels, to suit your analysis situation. 

Note: The application does not launch the Jitter Wizard when you start the 
application if you clear the Show This Wizard At Startup option.  
 

  

Figure 9: Jitter Wizard when launched 
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User Interface Information 

The application uses a Microsoft Windows based user interface. Display the 
definitions of the application user interface items, or view a menu labeled with 
the user interface items.  

Note: The oscilloscope application shrinks to half size and appears in the top half 
of the screen when the application is running. 

Table 5: User interface items 

 Item  Description 
Area Visual frame that encloses a set of related options 
Box Use to define an option; enter a value with the Keypad or 

a Multipurpose knob 
Browse Displays a window where you can look through a list of 

directories and files 
Button Use to define an option; not a command button  
Check box Use to select or clear an option 
Command button Initiates an immediate action, such as the Start command 

button in the Control panel 
Control panel Located to the right of the application; contains command 

buttons that you use often, such as to Start sequencing 
Keypad On-screen keypad that you can use to enter numeric 

values 
List box Use to select an option from a list 
Menu All options in the application window (except the Control 

panel) that display when you select a menu bar item 
Menu bar Located along the top of the application display and 

contains application menus 
Multipurpose 
knob 

Icon that indicates when you can use one of the 
multipurpose knobs on the oscilloscope front panel to 
adjust a value 

Option Any named button (other than a command button) or any 
named box that defines a control or task 

Status bar Line located at the bottom of the application display that 
shows the name of the current menu (location) and the 
latest Warning or Error message 

Tab Short cut to a menu in the menu bar or a category of 
menu options; most tabs are short cuts 

Virtual keyboard On-screen keyboard that you can use to enter 
alphanumeric strings, such as for file names 

Scroll bar Vertical or horizontal bar at the side or bottom of a 
display area that you use to move around in that area 
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Figure 10: Menu with user interface items 

 

Figure 11: Menu navigation tree 
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Setting Up the Application for Analysis 
The Jitter Wizard allows you to set up, configure, and launch a single 
measurement without requiring any knowledge of the control menus. However, it 
does not provide access to many of the advanced features. 

The Measurement Setup Sequence buttons show the logical order you would 
follow to set up the application if you do not use the Jitter Wizard. The menus 
from the menu bar allow the same full control as the Measurement Setup 
Sequence buttons, but are accessible at all times. 

When you use the Measurement Setup Sequence buttons or the menus, you may 
need to perform some or all of the following tasks:  
• Select up to six measurements  
• Configure measurement options  
• Configure waveform sources, such as the Source Autoset function 
• Create and configure up to four plots  
• Log statistics, measurements, or worst case waveforms  
• Take measurements and display the results  

After setting up the application, you can select the  or  command 
button to take measurements. The application displays the results as statistics, 
and as plots if you set up the Plot Create menu.  

After taking measurements, you can do any of the following tasks:  
• View the results as statistics  
• View the results graphically  

Selecting Measurements 

You can use the Measurements Select menu to select up to six measurements. 
You can always access the menu by selecting Measurements> Select in the menu 

bar. In addition, you can use the  button (when visible) as a short cut to 
the Measurements Select menus. 

To select a measurement, always choose the Source (or sources) first, and then 
select a measurement. To select a measurement, follow these steps: 
1. Select the Source in the Select Source area.  
2. Select a measurement in the Add Measurement area.  
3. For some advanced configurations, use the options in the Math Defs area in 

conjunction with the Source Select area. 

You can select the same measurement type multiple times using different 
sources. To do so, select a source first, and then select a measurement. You can 
also create two or more measurement entries that use the same measurement type 
and source, and then configure each measurement differently. 

You can view the configured measurements, sources, and any associated values 
in various Measurement Summary menus.  
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Figure 12:  Measurements Select menu 

Select Source Area 

The application takes measurements from waveforms specified as sources (also 
called input sources). You can select a live channel (CH1, CH2, CH3, or CH4), a 
reference (Ref1, Ref2, Ref3, or Ref4), or a math (Math1, Math2, Math3, or 
Math4) waveform as a source.  

The titles above the Select Source option list boxes vary depending on the 
measurement category. 

Note: Most measurements require one source. The Setup, Hold, Clock-to-Output, 
Skew, and Crossover Voltage (TDSJIT3 v2 Advanced only) measurements 
require two sources. 

Option names (in the Select Source area) vary with the category of 
measurements. 
            Clock  Data     Clk-Data         General 

     

Figure 13: Select Source options by measurement 
category 
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Table 6: Measurement definitions  
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Table 7: General measurement definitions  

Area Option Description 
General Rise Time Time difference between when the Lo reference level is 

crossed and the Hi reference level is crossed on the 
rising edge of the waveform 

 Fall Time Time difference between when the Hi reference level is 
crossed and the Lo reference level is crossed on the 
falling edge of the waveform 

 Positive Width Amount of time the waveform remains above the mid 
reference voltage level 

 Negative Width Amount of time the waveform remains below the mid 
reference voltage level 

 High Time Amount of time the waveform remains above the high 
reference voltage level 

 Low Time Amount of time the waveform remains below the high 
reference voltage level 

 Skew Difference in time between two similar edges on two 
waveforms with the assumption that every edge in one 
waveform has a corresponding edge (either the same or 
opposite polarity) in the other waveform; edge locations 
are referenced to the mid reference voltage level 

 Crossover 
Voltage 

Edge timing derived from the crossover (voltage) of 
differential clock or data measurements; for TDSJIT3 v2 
Advanced only 

  
Math Definitions 

The application includes four preset math operations and an option to use any 
other math operation as defined in the oscilloscope. You can assign each math 
waveform (Math1, Math2, Math3, or Math4) to any of these five operations. 

The Math Defs area includes the following preset math operations: 
• Ch1-Ch3 
• Ch2-Ch4 
• Ref1-Ref2 
• Ref3-Ref4 

You can select Scope User if you want to use a math waveform based on a user-
defined math operation. To define your own math operation, use the oscilloscope 
math equation editor. 
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Clearing Measurements 

You can remove individual or all selected measurements through the 
Measurements Select menu. To remove an individual measurement, follow these 
steps: 
1. Select the measurement to be removed in the table on the right side of the 

Measurements Select menu. 

2. Select the  button. 

3. To remove all selected measurements, select the  button. 

Configuring a Measurement 

Most measurements offer configuration options. The options available in each 
Configure Measurement menu are specific to the selected measurement. 

You can always access the menus by selecting Measurements> Configure in the 

menu bar. In addition, you can use the  button (when visible) as a short 
cut to the Configure Measurements menus. 

The application includes the following Configure Measurement menus: 
• General  
• Clock Recovery  
• Filters (TDSJIT3 v2 Advanced only) 
Configure Measurement Menus Definitions 

Table 8: File menus 

Menu name Description 
General Define waveform edges; define range limits for some 

measurements 
Clock Recovery Define reference clock frequency or PLL loop bandwidth for 

some measurements; advanced functions 
Filters* Define high pass, low pass, or band pass filters; advanced 

functions 
* TDSJIT3 v2 Advanced only. 
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Table 9: Configure Measurement menus and applicable 
measurements 

 
General 

You can select which waveform edge the application will use to take 
measurements. The name of the edge option depends on the measurement being 
configured. 

Edge options appear in the General Configure Measurement menu. Some 
measurements include two edge options because they require two waveforms.  

Note: Data measurements do not include Waveform Edge options. 
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Clock Edge Options 

The Clock Edge option defines which edge of the clock input is used to calculate 
the statistics of clock based measurements.  

  

Figure 14: Clock edge options 

Active Edge Options 

The Active Edge option defines which edge of the source waveform is used to 
take measurements. 

  

Figure 15: Active edge options 
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Clock and Data Edge Options 

The Clock Edge option defines which edge of the clock input is used to calculate 
the statistics of clock based measurements. The Data Edge defines which edge of 
the data input is used to calculate the statistics on clock-data based 
measurements. 

  

Figure 16: Clock and Data edge options 

From Edge and To Edge Options 

The From Edge option defines which edge on the first waveform is used to take 
the measurement. The To Edge option defines which edge on the second 
waveform is used to take the measurement, the same edge or the opposite edge as 
the first waveform. 

  

Figure 17: From Edge and To Edge options 
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Main Edge Options 

The Main Edge option defines which edge on the Main waveform is used to take 
the measurement. 

  

Figure 18: Main edge options 

Measurement Range Limits Configuration 

For two-channel measurements, you can specify the minimum and maximum 
range of valid measurement values. Individual measurements falling outside the 
selected range are discarded. 

The default values for the Meas Range Limits options vary by measurement. 

  

Figure 19: Meas Range Limits options 
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N-Cycle Measurement Configuration 

You can define a Clock Edge and some unique General Configuration options for 
the N-Cycle measurement. 

Table 10: N-Cycle measurement configuration 

Option Description 
Clock Edge Waveform edge used to calculate statistics 
N= Number of cycles in an N-cycle group 
1st Meas: Start @ Edge Number of cycles skipped prior to starting the 

measurement 
Edge Increment 
 
   1 
   N 

Specifies how consecutive measurements (each 
spanning 2 N-cycles) jump forward 
By one cycle in the waveform 
By N cycles in the waveform 

  
N-Cycle Measurement Options 

  

Figure 20: N-Cycle measurement options 
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Clock-Data-TIE Measurement Configuration 

You can define a Clock Edge and define Clock Delay Time to delay clock edges 
for this measurement in order to adjust its alignment with data edges or to take 
into account for transport delay. The Clock Delay Time configuration does not 
affect other measurements. You can also setup Rj/Dj separation for this 
measurement. 

 

Figure 21: Clock-Data-TIE measurement configuration 

 
TIE Rj/Dj 

Rj/Dj analysis refers to the process of separating jitter into the major categories 
of Random Jitter (Rj) and Deterministic Jitter (Dj), and further separating Dj into 
specific subcomponents based on observable properties of the jitter. This can 
help you understand and reduce the jitter in your circuit. For serial data signals 
with embedded clocks, it also allows you to accurately predict the eye opening 
and total jitter at very low bit error rates, in a few seconds. By contrast, direct 
measurement of these quantities can take hours for a single eye-opening 
measurement. 

For data signals, there are two methods of Rj/Dj analysis provided in the 
application. The Rj/Dj Analysis of Repeating Patterns Using a Spectral 
Approach, which requires a data signal with a cyclically repeating data pattern, is 
a method with wide industry acceptance. The Rj/Dj Analysis of Arbitrary 
Patterns method uses a technique that allows jitter separation and analysis even if 
the data pattern is random or unknown.  

Each method has advantages and limitations. For clock signals, the spectral 
analysis approach is automatically used. 

Once an Rj/Dj analysis has been done, the results may be plotted in the form of a 
Bathtub Plot.  
Rj/Dj Analysis of Repeating Patterns Using a Spectral 
Approach  

This method of Rj/Dj analysis uses a Fourier transform of the time-interval error 
signal to identify and separate jitter components. It is described in the Fibre 
Channel -- Methodologies for Jitter and Signal Quality Specification (MJSQ), 
and was the analysis method originally introduced with the TDSJIT3 application. 
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This method requires that the data signal be composed of a pattern of N bits that 
are repeated over and over. The pattern length (N) must be known, although it is 
not necessary to know the specific bits that make up the pattern. 

When the data pattern is not repeating, or is unknown, a second method of Rj/Dj 
analysis may be used. (It may also be used if the pattern is repeating, and 
correlates well with the Spectral method in this case.) This method assumes that 
the effects of Intersymbol Interference (ISI) only last for a few bits. For example, 
in a band-limited link where a string of ones follows a string of zeros, the signal 
may require three or four bit periods to fully settle to the "high" state. 

In this method, an analysis window with a width of K bits is slid along the 
waveform. For each position of the window, the time interval error of the right-
most bit in the window is stored, along with the K-1 bit pattern that preceded it. 
After the window has been slid across all positions, it is possible to calculate the 
component of the jitter that is correlated with each observed K-1 bit pattern, by 
averaging together all the observed errors associated with that specific pattern. 

In the configuration menu for the arbitrary-pattern method, the Window Length 
field allows you to select how many bits are included in the sliding window. The 
window should include enough bits to encompass the impulse response of the 
system under test, usually 5 to 10 bits. A good practical test is to check whether 
increasing the window length causes any appreciable change in the jitter results; 
if not, the window length is effectively capturing all the ISI effects. The 
disadvantage of increasing the window length is that it uses more memory and 
slows the processing. 

The configuration menu also includes a field for selecting what population of 
each K-1 bit pattern must be accumulated before the TIE associated with that 
pattern is considered accurate. Using a larger population means that more 
observations are averaged together, so that the variance of the measurement is 
reduced. Specifying a larger population has the disadvantage of requiring a 
longer measurement period before results can be calculated. 

It may be necessary to sequence the instrument several times before enough 
statistics are accumulated to provide results. A vertical gauge on the TIE:RjDj 
results screen provides an indication of how the accumulation is progressing. 

The arbitrary-pattern approach to measuring jitter may not be appropriate if there 
are very-long-duration memory effects in your data link. An example would be if 
there is impedance mismatch reflections that arrive long enough after the initial 
edge to fall outside the analysis window. 
Bathtub Curve and BER Versus Decision Time 

The Bathtub Curve plot shows the eye opening and total jitter values as functions 
of the BER level. The plot is obtained from the Rj/Dj separation. 
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Figure 22: Bathtub Curve and BER versus Decision Time 

Table 11: TIE: RjDj analysis configuration 

Option Description 
Separation Enables or disables Rj/Dj separation analysis 
Total Jitter 
   BER=1E-? 

 
Sets the BER level for the eye opening and total jitter 

Data Pattern*  
   Type* Selects a Repeating or an Arbitrary data pattern 
   Pattern Length* When the Type option is set to Repeating, sets the 

pattern length of the repetitive pattern data; use for 
spectrum analysis Rj/Dj separation 

   Window Length* When the Type option is set to Arbitrary, sets the pattern 
window length used for arbitrary pattern Rj/Dj separation 

   Population* When the Type option is set to Arbitrary, sets the 
minimum population limit for each pattern to be qualified 
for arbitrary pattern Rj/Dj separation 

* Available only for Data TIE and Data PLL TIE measurements. 
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Figure 23: TIE: RjDj analysis options for Clock TIE 
and Clock PLL TIE 

 

Figure 24: TIE: RjDj analysis options for Data TIE and 
Data PLL TIE 

Clock Recovery Configuration 

For waveforms that are synchronized to a nominal clock frequency, TIE 
measurements offer a choice of clock recovery methods. Clock recovery is 
defined as the way in which the TDSJIT3 v2 application determines the 
theoretically jitter-free clock to which the waveform will be compared. 

Constant (straight line) clock recovery is implicitly chosen by selecting a Clock 
TIE or Data TIE measurement. Phase-Locked Loop clock recovery is chosen by 
selecting a Clock PLL TIE or Data PLL TIE measurement. 

For Data measurements (Data Period, Data Frequency, Data TIE, and Data PLL 
TIE) on signals with extremely high jitter, advanced clock recovery support is 
offered. This support is not needed or recommended for most signals. It allows 
you to provide extra guidance to the clock recovery algorithm with respect to 
how many unit intervals are represented by each pair of clock edges. This is most 
useful in cases where the total jitter on a data signal exceeds 0.5 unit intervals. 

In Constant Clock Recovery, the clock is assumed to be of the form  
A*sin(2πft +ϕ), where the frequency (f) and phase (ϕ) are treated as unknown 
constants. Once a source waveform has been acquired and the edges extracted,  
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f and ϕ are chosen using linear regression, so that the recovered clock minimizes 
the mean-squared sum of the Time Interval Error (TIE) for that waveform. 

  

Figure 25: Constant Clock Recovery concept 

Constant Clock Recovery Setup 

The Ref Clock Frequency control area provides three options that control how 
the clock recovery is performed. 

Selecting Autocalc Every Acq will allow the clock-recovery algorithm to choose 
a new best-fit clock frequency and phase for each new oscilloscope acquisition. 

Selecting Autocalc 1st Acq will allow the clock-recovery algorithm to choose a 
new best-fit clock frequency and phase only on the first acquisition. Subsequent 
acquisitions will choose a best fit on clock phase but retain the clock frequency 
found on the first acquisition. Clearing the measurements by choosing Clear on 
the control panel will reset the clock recovery so that both frequency and phase 
are optimized on the subsequent acquisition. 

Selecting Custom allows you to specify an exact clock frequency, so that 
absolutely no clock frequency optimization is performed. A best fit of the clock 
phase is still performed on every acquisition. 

Table 12: Reference Clock Frequency configuration 

Option Description 
Autocalc 1st Acq Calculates the best fit of the initial acquisition or the 

first acquisition after clearing results, and then uses the 
value until you clear the results 

Autocalc Every Acq Calculates the best fit for each acquisition (default) 
Custom: Value Uses the exact frequency you enter 
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Figure 26: Reference Clock Frequency options 

Phase-Locked Loop (PLL) Clock Recovery 

In PLL Clock Recovery, the application simulates the behavior of a hardware 
phase-locked loop clock recovery circuit. This is a feedback loop in which a 
voltage-controlled oscillator is used to track, or follow, slow variations in the bit 
rate of the input waveform. Such loops are frequently used to recover the clock in 
communication links that do not transmit the clock as a separate signal. The PLL 
parameters in the application may be adjusted to mimic the behavior of a receiver 
in such a link, within certain guidelines. 

  

Figure 27: Phase-Locked Loop (PLL) Clock Recovery 
concept 

PLL Clock Recovery Setup 

The PLL control area provides control over the phase-locked loop used for clock 
recovery. You can choose the loop bandwidth and the loop order, and if a 
second-order loop is chosen, you can specify the damping factor. 

The loop bandwidth can be selected implicitly by specifying a data 
communications standard, or it can be set explicitly. 

To use a standards-based setup, select the Standard Frequency button. From the 
Standard: Speed (Gb/s) list box, choose the standard that matches your data link. 
For example, choose "FC2125: 2.125" to test a 2.125 Gbit/second Fibre Channel 
link. The PLL bandwidth will be set to 1/1667 of the baud rate. 
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To manually control the loop bandwidth, choose the User button and use the 
Value option to select the 3 dB bandwidth of the loop, in Hertz. 

You can use the PLL Order list box to choose between a first-order or second-
order loop. More correctly, this is the loop type, where a type 1 loop has a 
transfer function that approaches zero frequency with a slope of 1/s and a type 2 
loop approaches zero frequency with a 

21 s  slope. The term Order is used in the 
application as a concession to popular usage. For a more thorough treatment of 
loop type and order, see Frequency Synthesis by Phase Lock, by William Egan. 

If you choose a second-order loop, the Damping option becomes enabled. (The 
Damping Factor does not apply to first-order loops.) 

Note: Although it is possible to configure a second-order PLL with a bandwidth 
up to 1/10 of the baud rate, such a loop will have poor dynamic performance. 
This is because second-order loops have less phase margin than first-order loops. 
A preferred alternative to using a second-order PLL with a high bandwidth is to 
use a second-order high-pass measurement filter to emulate the effects of the 
PLL. 

Table 13: PLL Loop Bandwidth configuration 

Option Description 
Standard 
Frequency 

Select a standard:  
FC133:0.1328, FC266:0.2656, FC531:1.0625, 
FC1063:11.063,: FC2125:2.125, IB2500:2.5, SerATAG1:1.5, 
SerATAG2:3, SerATAG3:6, USB_FS:0.12, USB_HS:0.48, 
1394b_S400b:0.4915, 1394b_S800b:0.983, 
1394b_S1600b:1.966, GB_Ethernet:1.25, 100BaseT:0.125, 
OC1:0.0518, OC3:0.155, OC12:0.622, OC48:2.488 

Custom: Value Sets the 3 dB bandwidth of the Phase Locked Loop (PLL)  
PLL Order Sets the order of the PLL 
Damping Sets the damping ratio of the PLL 
Advanced*  
* Available only for Data PLL TIE measurements. 
  
Loop BW Options 

  

Figure 28: PLL Loop Bandwidth options 



Operating Basics  

 

 TDSJIT3 v2 Jitter Analysis Online Help 

 

32 

Advanced Clock Recovery Setup 

For Data Period, Data Frequency, Data TIE and Data PLL TIE measurements, 
you may use several types of advanced clock recovery if needed. The advanced 
clock recovery tools can be helpful if your signal has jitter excursions that exceed 
0.5 unit intervals, by guiding the application in choosing the number of unit 
intervals that correspond to each pair of edges. Advanced clock recovery is 
seldom required, and is not recommended for general analysis. 

When Advanced Clock Recovery is enabled for a given source, it applies to all 
Data measurements using that source. For example, if you have Data Period and 
Data TIE measurements on Channel 1, enabling advanced clock recovery for one 
measurement will cause it to be enabled for the other as well. 

Two types of advanced clock recovery are available. In the first, you can provide 
the nominal data rate to the clock recovery algorithm. Normally, the application 
analyzes your data and determines the nominal data rate automatically. If you 
know the data rate or unit interval to an accuracy of ± 3%, you can provide this 
information as a clue to the algorithm. 

You can also provide clock recovery guidance in the form of a known data 
pattern. The pattern is specified by using an ASCII text file containing the 
characters 1 and 0. The file may contain other characters, spaces and tabs for 
formatting purposes, but they will be ignored. Several files for commonly-used 
patterns are included with the application, and you may use these as examples if 
you wish to create your own pattern files. The default location for pattern files is 
C:\TekApplications\TDSJIT3v2\patterns. 

If you use pattern file guidance, the clock recovery algorithm will perform a best 
fit of the selected data pattern against the acquired edge sequence. It will then use 
the pattern file to determine the number of unit intervals that fall between each 
set of edges. 

Note: Clock recovery using pattern match will provide erroneous results if your 
data has missing edges or extra edges at the defined edge threshold. 
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Table 14: Advanced Clock Recovery configuration 

Area/option Description 
Nominal Data Rate  
   On Off Enables or disables advanced clock recovery through 

rate guidance 
   Unit Interval Defines the nominal data rate by UI in time 
   Bit Rate Defines the nominal data rate by the bit rate in 

frequency 
Known Data Pattern  
   On Off Enables or disables advanced clock recovery through a 

known data pattern 
   Pattern File Name Selects a file to use for the data pattern 
OK button Accepts changes and closes 
Cancel button Discards changes and closes 
  

  

Figure 29: Advanced Clock Recovery options 

Filters 

For some measurements (Clock Period, Clock Frequency, Clock TIE, Clock PLL 
TIE, Data Period, Data Frequency, Data TIE, and Data PLL TIE), the 
measurements-versus-time waveform (time trend) that is derived from the 
original oscilloscope waveform can be filtered before it is passed to the statistics 
and plotting subsystems. 

  

Figure 30: Optional filters 
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You can modify the time trend by applying filters that block specific frequency 
bands. You can configure a High Pass filter to block out the low frequency band 
or a Low Pass filter to block out the high frequency band. 

  

Figure 31: Filter characteristics 

Band Pass Filtering 

You can create a band pass filter by enabling both the High Pass and Low Pass 
filters on a measurement. The cutoff frequency for the Low Pass filter must be 
greater than or equal to the cutoff frequency for the High Pass filter.  

You should be aware that setting the cutoff frequencies close to each other may 
effectively filter out all of the time trend, or all but a small amount of noise. This 
diagram shows the spectrum of the time trend passed to the statistics and plotting 
subsystems when you use both the High Pass and the Low Pass filters. 

  

Figure 32: Band Pass filtering 
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Influence of High Pass Filters on Period and Frequency 
Statistics 

High-pass filters attenuate low frequencies, and filter out DC values entirely. 
When a high-pass filter is added to a period or frequency measurement, the mean 
value of the filtered measurement goes to zero. This can be seen by creating a 
Time Trend plot of a high-pass-filtered period or frequency measurement. 
Although this is the correct theoretical behavior for the filtered measurement, it is 
not very useful if the Results panel reports that the mean period or frequency is 
zero. For this reason, the mean values that appear in the results panels for Period 
and Frequency measurements are the values prior to the filter. 

Table 15: Filters configuration 

Option Description 
High Pass  
   Filter Spec When enabled, blocks the low frequency band and 

passes on only the high frequency band of the 
waveform; defined as 1st order, 2nd order, or 3rd order 
Butterworth 

   Freq (F1)* High Pass filter cutoff frequency; frequency at which 
the filter magnitude has dropped by 3 dB 

Low Pass  
   Filter Spec When enabled, blocks the high frequency band and 

passes on only the low frequency band of the 
waveform; defined as 1st order, 2nd order, or 3rd order 
Butterworth 

   Freq (F2)* Low Pass filter cutoff frequency; frequency at which the 
filter magnitude has dropped by 3 dB 

* Includes a 3 dB attenuation. 
  

These options are also available for Data measurements. 

  

Figure 33: Filters options 
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Advanced Filter Configuration 

The measurement filters are implemented using infinite impulse response (IIR) 
designs. As with any causal filter, a transient may occur at the filter’s output in 
response to the arrival of the input signal. It is usually desirable to exclude this 
transient from the measurement results. 

In the TDSJIT3 v2 application, the filter transient is managed by specifying a 
settling time, Td. A smoothing window ramps the filter input from 0 to 1 during 
this settling time. The output of the filter during the settling time is excluded 
from the measurement results. The smoothing window has a raised-cosine profile 
which is described by: 
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where the settling time of the filter (Td) is configurable. The operation of the 
smoothing window is shown graphically in the Effect of the Smoothing Window 
topic. 

By default, the settling time is set to 2/Fc, where Fc is the lowest filter cut-off 
frequency applied to the measurement. 

Note: Setting the settling time to less than 1/Fc increases the chance that the 
measurement results will include effects that are due to the filter transient. The 
user interface will warn you if you configure the measurement this way. 

Table 16: Advanced Filter configuration 

Option Description 
Duration Defines the amount of time excluded from the measurement 

results to allow the filter to settle 
OK button Accepts changes and closes 
  

  

Figure 34: Advanced Filter options 
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Figure 35: Effect of the Smoothing window 

Configuring Sources 

You may configure the sources associated with your measurements, which can be 
as simple as using the Autoset features that automatically calculate the scale or 
the reference voltage levels. 

You can always access the menus by selecting Measurements> Source in the 

menu bar. In addition, you can use the  button (when visible) as a short 
cut to the Configure Measurements menus. 

The application includes the following Configure Source menus: 
• Autoset  
• Gate/Qualify 
• Ref Levels 
• Stat Pop Limit 
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Table 17: Configure Sources menus 

Menu name Description 
Sources Autoset* Automatically changes the vertical scale or horizontal 

resolution of the measurement source waveforms 
Autoset acts on all active (Ch1, Ch2, Ch3, Ch4) sources 
used by measurements directly or contained in a math 
source definition 
Accurate measurement results require sufficient vertical 
and horizontal resolution 

Gate/Qualify* Gating limits measurements to an area of the source 
waveform bounded on the left and right by vertical cursors 
or by the lowest zoom that is on   
Qualify limits measurements to the one or more areas of 
the waveform where a qualifier waveform is active 

Ref Levels Specifies reference voltage levels for each measurement 
source; separate reference levels apply to rising and falling 
edges 

Stat Pop Limit** Sets the maximum population of all measurements; Free 
Run sequencing mode will stop when all measurements 
have attained this limit 

* All sources must have the same Horizontal Sample Rate, Record Length, and 
Position to assure that measurements function properly. 
** In Free Run mode, sequencing stops when all the population limits are met. 
  
Autosetting Sources for Live (Channel) Waveforms 

In most situations, you can improve accuracy on channel or math waveform by 
using the Source Autoset options to optimize the vertical scale or horizontal 
resolution settings of the oscilloscope. 

The Vertical Scale option automatically checks the Peak-to-Peak level of live 
sources. The vertical scale and offset of all signals with a Peak-to-Peak less than 
six divisions is adjusted so the Peak-to-Peak will be eight divisions. If the 
maximum or minimum value of a signal is "clipped," the vertical scale and offset 
is adjusted so the Peak-to-Peak will be 8 divisions. 

The Horizontal Resolution option automatically checks the number of 
samples/edge on the rising and falling transitions (Rise Time/Resolution and Fall 
Time/Resolution) of all live channels. The oscilloscope horizontal resolution is 
set to the largest value that does not cause the samples/edge of the fastest edge to 
fall below the specified target. The target is five samples per edge when 
optimized for edge resolution, and 2.5 samples per edge when optimized for edge 
count. Horizontal Resolution sets the acquisition sampling mode to Interpolated 
Real Time for signals with very high edge speeds. The default record length is 
500 k points. 
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To automatically define both the vertical and horizontal settings for all channel 
sources, select the All button. The All option also applies an oscilloscope Autoset 
on each channel prior to performing the vertical scale and horizontal resolution 
autoset. 

To automatically define the vertical or horizontal settings for active sources, 
follow these steps: 
1. Ensure that any channel waveform that you want to autoset is visible on the 

oscilloscope. 
2. If you intend to select the All or Horizontal Resolution button, configure the 

Optimize Horizontal For option to one of the following: 

• Edge Resolution: results in five samples per edge or more, giving you 
better edge timing and measurement accuracy. 

• High Edge Count: results in as few as 2.5 samples per edge. Some edge 
timing accuracy is sacrificed for more edges in a given record length. High 
edge count is desirable for RjDj analysis in oscilloscopes without extended 
record lengths. 

3. Select one of the following options: 

• All button to Autoset both vertical and horizontal setting 

• Vertical Scale button to Autoset oscilloscope vertical settings only 

• Horizontal Resolution button to Autoset oscilloscope horizontal settings 
only 

Optionally, select the Undo button to return the oscilloscope to its state prior to 
autoset.  

Note: At rise times less than 100 ps, the application may have only two actual 
sample points per edge to work with. The application will set up a suitable level 
of oscilloscope acquisition interpolation to increase the point count per edge to 
around five points. 

Table 18: Configure Sources Autoset configuration 

Option Description 
All Performs a sequence: oscilloscope AUTOSET, Vertical 

Scale, and Horizontal  Resolution 
Vertical Scale If a channel waveform does not exceed six vertical 

divisions, decreases the scale so the waveform 
occupies about eight divisions  

Horizontal Resolution Sets the horizontal resolution so that the number of 
samples on the fastest transition (edge) exceeds a 
specified target; see Optimize Horizontal For option 

Undo Returns to the settings present before an Autoset was 
performed; disabled after measurements are taken until 
you perform another Source Autoset 
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Table 19: Optimize Horizontal For configuration 

Area/option Description 
Optimize Horizontal For  
   Edge Resolution Sets the horizontal scale to ≥ 5 samples per 

transition; edge timing accuracy does not improve 
significantly at higher resolution 
Edge timing accuracy will not significantly improve 
at higher resolution (default) 

   Max Edge Count Sets the horizontal scale to ≥ 2.5 samples per 
transition; Rj/Dj analysis requires a larger data set 
If the oscilloscope does not have a long acquisition 
memory, it may be necessary to trade some Edge 
timing accuracy for a larger data set 

  

  

Figure 36: Configure Sources Autoset options 

Gate/Qualify 

Gating allows you to limit the analysis to a specific area of the waveform 
bounded by cursors or zoom limits, thereby excluding unnecessary information. 
To access the Gating menu, select Measurements> Configure Source> Source 
Gate/Qualify. View the Configure Sources Gate/Qualify menu.  

You can set up a gated region in one of the following ways: 
• Zoom 
• Cursors (vertical) 

Qualifiers allow you to limit the application to more narrowly defined conditions 
before taking measurements. This is another way to exclude unnecessary 
information. All sources for the measurements and Qualify input must have the 
same Horizontal Sample Rate, Record Length, and Position to ensure that 
measurements function properly. For TIE and PLL TIE measurements, only the 
first qualified region will be measured even if multiple qualified regions are 
present. 

Table 20: Configure Sources Gating configuration 
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Option Description 
Off No gating occurs; application takes measurements over the entire 

waveform 
Zoom Zoom to a specified region of the source waveform and take 

measurements within the selected area 
Cursors Use oscilloscope cursors to define a specific part of the waveform 

and take measurements within the selected area  
  
Configure Sources Gate/Qualify Menu 

  

Figure 37: Configure Sources Gating options 

Table 21: Configure Sources Qualify configuration 

Option Description 
Source* Selects a waveform to qualify the signal or clock source used 

for the measurement 
   Mid Shows the vertical reference level of the qualifier waveform 
   Hysteresis Shows the vertical reference margin of the qualifier waveform 
Active  
   Off Disables the use of the qualify waveform 
   High Enables measurements in regions** where the qualifier 

waveform exceeds the mid reference level 
   Low Enables measurements in regions** where the qualifier 

waveform falls below the mid reference level 
* Measurement and Qualify sources must have the same Horizontal Sample Rate, 
Record Length, and Position to ensure that measurements function properly. 
** For TIE and PLL TIE measurements, only the first qualified region will be 
measured even if multiple qualified regions are present. 
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Ref Levels 

Timing measurements are based on state transition times. By definition, edges 
occur when a waveform crosses specified reference voltage levels. Reference 
voltage levels must be set so that the application can identify state transitions on 
a waveform. By default, the application automatically chooses reference voltage 
levels when necessary. 

The TDSJIT3 v2 application uses three basic reference levels: High, Mid and 
Low. In addition, a hysteresis value defines a voltage band that prevents a noisy 
waveform from producing spurious edges. The reference levels and hysteresis are 
independently set for each source waveform, and are specified separately for 
rising versus falling transitions. 

There are two ways to set the reference voltage levels: automatically or 
manually. 
High, Mid and Low Reference Voltage Levels 

The application uses three reference voltage levels: High, Mid, and Low. 
• For most measurements, the application only uses the Mid reference voltage 

level. The Mid reference level defines when the waveform state transition 
occurs at a given threshold. 

• For Rise Time and Fall Time measurements, the High and Low reference 
voltage levels define when the waveform is fully high or low. 

  

Figure 38: Reference voltage levels diagram 

Rising Versus Falling Thresholds 

You can specify thresholds for each of the reference voltage levels: High, Mid, 
and Low. The application uses the thresholds to determine the following events:  
• A Low/Mid/High rising event, which occurs when the waveform passes 

through the corresponding Rise threshold in the positive direction. 
• A Low/Mid/High falling event, which occurs when the waveform passes 

through the corresponding Fall threshold in the negative direction. 

For a given logical reference level (such as Low, Mid, or High), rising and falling 
events alternate as time progresses. 

Note: In many cases, the rising and falling thresholds for a given reference 
voltage level are set to the same value. In those cases, a hysteresis value helps 
prevent spurious edges produced by small amounts of noise in a waveform. 
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Using the Hysteresis Option 

The hysteresis option can prevent small amounts of noise in a waveform from 
producing multiple threshold crossings. You can use a hysteresis when the rising 
and falling thresholds for a given reference voltage level are set to the same 
value. 

The reference voltage level ± the hysteresis value defines a voltage range that 
must be fully crossed by the waveform for an edge event to occur. If the decision 
threshold is crossed more than once before the waveform exits the hysteresis 
band, the mean value of the first and last crossing are used as the edge event 
time.  

For example, if the waveform rises through the Threshold - Hysteresis, then rises 
through the Threshold, then falls through the Threshold, then rises through both 
the Threshold and the Threshold + Hysteresis, a single edge event occurs at the 
mean value of the two rising crossings. 
Example of Hysteresis on a Noisy Waveform 

  

Figure 39: Example of Hysteresis on a noisy waveform 

Automatic Versus Manual Reference Voltage Levels 

Each measurement source may be configured to automatically choose voltage 
reference levels (default), or to lock the reference voltages to levels of your 
choosing. 

In the Ref Levels configuration panel, a table at the left edge contains all of the 
currently active measurement sources. An Autoset checkbox appears beside each 
source. To enable or disable Autoset for a given source, choose the source button 
in the left column and select the corresponding checkbox to toggle its state. 

To learn more about automatically or manually setting voltage reference levels, 
refer to Understanding When Ref Level Autoset will Occur and Understanding 
How Ref Level Autoset Chooses Voltages.  
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Table 22: Configure Sources Ref Levels Autoset 
configuration 

Option/button Description 
Autoset Identifies which sources on which to perform an autoset; you 

can set or clear the option for each source 
Update* Immediately calculates and displays the reference voltage 

levels for all sources where the Autoset option is set 
according to the Autoset Ref Level Setup menu  

Setup Specifies the Base-Top method and relative percent to be 
used for all reference voltage levels when an autoset occurs 

*If you do not select this button, the application updates the reference levels (if 
needed) when you select the Single or Run/Stop button to take measurements. 
  
Understanding When Ref Level Autoset will Occur 

When Autoset is enabled for a given source, the individual reference levels are 
displayed but you may not manually adjust them. Instead, the reference levels are 
automatically recalculated whenever one of the following events occurs: 
• A measurement sequence is initiated for the first time after a source has 

become active 
• A measurement sequence is initiated for the first time after all results have 

been cleared 
• The "Update" button at the right edge of the panel is pressed 

The Update button is provided as a convenience, but it is never required. Autoset 
will always be run (if enabled) before an uninitialized source is used for a 
measurement. 

An "Armed" indicator appears in the upper right corner of the panel whenever a 
new source has been added or measurement results have been cleared. This lets 
you know that the reference levels will be recalculated the next time either the 
Single or Run/Stop button is selected. If the "Armed" indicator is not visible, the 
displayed reference levels will be retained if a measurement sequence is 
performed with no further configuration changes. You can cause the reference 
levels to be recalculated at any time by selecting the Update button. 
Understanding How Ref Level Autoset Chooses Voltages 

Once triggered, the Reference Level Autoset function uses the following logic to 
determine actual voltage levels. 

For each applicable source, the Top (high logic level) and Base (low logic level) 
are first determined. Then, the High, Mid and Low levels are calculated as 
percentages of the Top-Base difference. For example, if the Top and Base were 
2.8 volts and 0.4 volts respectively and the High percentage level was 90%, this 
threshold would be calculated as: 
 

56.2)4.08.2(9.04.0)( =−⋅+=−⋅+= BaseToptHighPercenBaseHighThresh  
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You can select the method used for calculating the Top and Base of the 
waveform, as well as the percentages used for the High, Mid and Low thresholds, 
for each source. To do so, see the Configure Source Ref Levels Autoset Options 
topic.  

Table 23: Configure Sources Ref Levels Autoset 
configuration 

Area/option Description 
Base-Top Method  
   Min-Max Uses the minimum and maximum values in the 

waveform to determine the base-top amplitude 
Useful on a waveform with low noise and free from 
excessive overshoot 

   Low-High (Histogram) Uses a histogram approach to determine the base-
top amplitude 
Creates a histogram of the amplitudes of the 
waveform; the histogram should have a peak at the 
nominal high level, and another peak at the nominal 
low level 

   Auto Automatically determines the best Base-Top Method 
to use 

Set Ref Level % 
Relative to Base-Top* 

 

   Rise High Sets the high threshold level for the rising edge of 
the source 

   Rise Mid Sets the middle threshold level for the rising edge of 
the source 

   Rise Low Sets the low threshold level for the rising edge of the 
source 

   Fall High Sets the high threshold level for the falling edge of 
the source 

   Fall Mid Sets the middle threshold level for the falling edge of 
the source 

   Fall Low Sets the low threshold level for the falling edge of 
the source 

   Hysteresis Sets the threshold margin to the reference level 
which the voltage must cross to be recognized as 
changing; the margin is the relative reference level 
plus or minus half the hysteresis; use to filter 
spurious events 

* Default settings are 90% (High), 50% (Mid), 10% (Low), and 3% (Hysteresis). 
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Figure 40: Autoset Ref Levels options 

Manually Adjusting the Reference Voltage Levels 

Whether or not you use the application to automatically calculate the initial 
reference voltage levels, you may need to manually change the values. To set the 
reference levels manually, follow these steps:  
1. Select Measurements> Configure Sources> Ref Levels. 
2. Select the desired source from the Source column. 

Note: You cannot select sources that are not currently active. 
3. Clear the Autoset option for the source you wish to set manually.  
4. Select the reference levels or hysteresis options and manually adjust the 

values. The values will not change when you select the Update button or take 
measurements. 

Once an active source has been set to Manual, the reference levels for that source 
will not change when you select the Update button or take measurements. 

Note: A source will become inactive if all measurements on that source are 
removed. If a new measurement is then added on that source, the source once 
again becomes active, and defaults to Autoset. If you clear all measurements on a 
source that was set to Manual, you must re-select the Manual state (if desired) 
when the source is again added. 
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Table 24: Configure Sources Ref Levels configuration 

Area/option Description 
Autoset (Source)  
   Set (enabled) Allows the application to automatically calculate 

reference voltage levels when necessary 
The calculation occurs when you select the Single or the 
Run/Stop button to start sequencing after a change to the 
configuration or when you select the Update button 

   Clear (disabled) Prevents the application from changing the reference 
voltage levels from the values you set  

Autoset  
   Armed Visible only when an Autoset will occur on the next 

measurement sequence 
   Update* Immediately calculates and displays the reference 

voltage levels for all sources where the Autoset option is 
set  

   Setup Displays the Autoset Ref Level menu where you can 
adjust the relative percent values or select a Base-Top 
method 

Reference Level**  
   Rise High Sets the high threshold level on the slope in volts for the 

rising edge of the source 
   Rise Mid Sets the middle threshold level on the slope in volts for 

the rising edge of the source 
   Rise Low Sets the low threshold level on the slope in volts for the 

rising edge of the source 
   Fall High Sets the high threshold level on the slope in volts for the 

falling edge of the source 
   Fall Mid Sets the middle threshold level on the slope in volts for 

the falling edge of the source 
   Fall Low Sets the low threshold level on the slope in volts for the 

falling edge of the source 
   Hysteresis Sets the threshold margin relative to the reference level 

which the voltage must cross to be recognized as 
changing; the margin is the reference voltage level plus 
or minus half the hysteresis; use to filter out spurious 
events 

*If you do not select this button, the application updates the reference levels (if 
needed) when you select the Single or Run/Stop button to take measurements. 
** Default settings are 90% (High), 50% (Mid), 10% (Low), and 3% (Hysteresis) 
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Figure 41: Configure Sources Ref Levels options 

Stat Pop Limit 

The Population control allows you to limit the amount of waveform data that is 
analyzed. You can use the Configure Source Stat Pop Limit menu to set a limit 
on a maximum population to obtain for all selected measurements. View the 
Configure Source Statistics Population Limit menu.  

To define the maximum population for measurements, follow these steps: 
1. Select Measurements> Configure Source> Stat Pop Limit > On. 
2. Specify a value for the Size option from one to one million. 

If you use a population limit, statistics individually accumulate for each 
measurement until the population limit is reached. A Free Run stops sequencing 
when all active measurements reach the population limit. A Single Run stops 
sequencing when the limit is less than the normal population for that Single Run. 

Note: Statistics stop accumulating for an individual measurement when it reaches 
an internal limit of two billion. The application stops sequencing when all 
selected measurements have reached this internal limit. 

Table 25: Configure Sources Stat pop Limit 
configuration 

Option Description 
On 
Off 

Enables or disables the application from using a population limit 
while taking measurements 

Size Specifies the maximum population to obtain for each active 
measurement  

  



 Operating Basics 

TDSJIT3 v2 Jitter Analysis Online Help 

 

49

  

Figure 42: Configure Sources Stat pop Limit options 

Measurement Summaries 

You can view various summary menus that show measurement settings. 

Table 26: Measurement Summaries menus 

Menu name Description 
Measurement Shows the names of each selected measurement, the 

waveform sources for each measurement, and the 
configuration parameters for each measurement  

Source Ref 
Levels 

Shows the reference voltage levels for the high, mid, and 
low thresholds for the rising edge and for the falling edge of 
each active source, plus the hystersis 

Miscellaneous Shows if Gating, Qualify, and Stat Pop Limit functions are 
enabled; if enabled, also shows the Source for qualification 
the Size for population, and various other configuration 
choices.  

  

Taking Measurements 
If you want to change trigger settings or localize the measurement, you should do 
so before you take any measurements.  

Note: If an error message displays because there are not enough cycles from 
which to take a measurement, adjust the Horizontal setting on the oscilloscope to 
increase cycles. 

Note: If you select a reference waveform as the source, you need to recall and 
display the waveform on the oscilloscope before the application can take a 
measurement. To do so, refer to recalling a waveform file. 
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Localizing Measurements 

By specifying the trigger position, the starting point, and the length of the 
waveform, you can effectively exclude information that is not useful to analyze 
before taking a measurement.  

To limit the application measurement to a part of the waveform, you can use the 
Configure Source Gate/Qualify menu. You can also adjust the Record Length, 
Scale, or pre-trigger information in the oscilloscope Horizontal menu, or the 
Trigger Level and Slope in the oscilloscope Trigger menu. 

About Sequencing 

You use the Control Panel to start or stop the sequence of processes for the 
application and oscilloscope to acquire information from a waveform. The 
application then determines if the algorithm for the selected measurement can be 
applied to the waveform information. Sequencing is the steps to acquire 
waveform information, determine if the information is usable for the 
measurement, take the measurement, and display the results (and plots if 
selected).  

Acquiring Data 

To acquire data from waveforms and take measurements, follow these steps: 

1.  If the Control Panel is not displayed, select the  button or select any 
menu from the Results drop down list. 

2.  Select the  Run/Stop button for continuous acquisitions. This is called 
the Free Run mode. 

Select the  Single button for a single acquisition. The application 
displays the results when the sequencing is complete. 
Note: If none of the selected measurements is a live source (or a Math 
expression which includes a live source), Free Run mode will stop after a 
single sequence since there is no point in repeatedly analyzing the same data. 

To stop sequencing, do one of the following: 
• If you wish to stop a Single measurement sequence before it is complete, 

select the Single button a second time. This may be useful if you have started 
a sequence on a long waveform and then realize you would like to change the 
configuration. 

• If you wish to interrupt a Free Run as quickly as possible, select Run/Stop a 
second time. Sequencing will be halted as quickly as practical but the final 
measurement cycle may include results from only part of a waveform. 

• If you wish to halt a Free Run cleanly, select the Single button. This will 
convert the Free Run mode to Single mode, so that the sequencer stops when 
the latest measurement cycle is complete. This is the preferred method since 
all accumulated measurement results will include the same number of 
complete measurement cycles. 
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Note: The status bar at the bottom of the Control Panel indicates the current 
sequencer state. It displays Sequencing when either Single or Free Run 
measurements are in process. The status bar indicates Ready when the 
sequencing is complete. It may also indicate Stopping when a measurement cycle 
has been interrupted, prior to indicating Ready. 

 Use the  command button to delete all measurement results. 

New Acquisition Function of the Single Button 

You may wish to perform additional measurements on the current waveform(s) 
rather than acquiring new waveforms. For example, you may wish to make more 
than six measurements on a single waveform. Or you may decide after 
performing a measurement cycle that you would like to perform a slightly 
different measurement on the same data. To do this, follow these steps: 

1. Take the first measurements using the  Single button. 

2. Select the  button to change the New Acq setting from Yes to No. 
3. Select and configure the next set of measurements and press the Single button 

again. 
4. When you are ready to acquire new data, select the New Acq button again to 

change the setting to Yes. 

Note: If Run/Stop is selected while the New Acq button is set to No, the 
application will change the button to Yes and Free Run will proceed. 

Control Panel Functions 

Table 27: Control Panel functions 

Command 
button 

 
Description 

Run/Stop  
(Free Run)* 

Continuously acquires waveforms and sequences until you 
select the Run/Stop or Single command button again 

Single Acquires a new waveform if the source is Ch1, Ch2, Ch3, or 
Ch4; for all sources, the application sequences until complete 
and displays the results (and plots if selected) 

New Acq = No Without acquiring new data, calculates the statistical results 
for the selected measurements and displays the results (and 
plots if selected) 

Clear Clears all previous information in the Results menus and Plot 
windows; data saved to files remains intact (.csv, .wfm, etc.) 

*Stops when the sequencing reaches the population limit; plots also display (if 
selected) when you select Stop. 
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Figure 43: Control Panel options 

There are two ways to view the results after an analysis is complete: as statistical 
values or as graphical plots.  

If you set up plots before taking measurements, the application shows the 
selected plots in a separate window in the oscilloscope part of the display. The 
application shows statistics in the application part of the display. Each selected 
plot appears in its own window, which initially occupies the upper half of the 
display in front of the oscilloscope waveform. 

You can also log the measurement data and measurement statistics to .csv files 
for viewing in a spreadsheet, database, text editor or data analysis program. 

Clearing Results 

Before taking more measurements, you may want to clear the results. To do so, 

select the  command button in the Control Panel. Clearing the results 
does not clear log files. 

Note: Measurement log files will be overwritten with new data and results the 
next time you select the Run/Stop or Single buttons to take measurements.  
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Results as Statistics 

Table 28: Statistics menus 

Statistics menu Description 
All  For each individually selected measurement, shows 

numeric values for the population, mean, standard 
deviation, maximum, minimum, peak-to-peak, positive 
deviation, and negative deviation characteristics; two sets 
of values display results for the current acquisition and for 
all acquisitions 

Min/Max For all selected measurements, shows the sources and 
numeric values for the population, maximum, minimum, 
positive deviation, and negative deviation characteristics; 
you can display values for the current acquisition or for all 
acquisitions 

Mean/Std Dev For all selected measurements, shows the sources and 
numeric values for the population, mean, and standard 
deviation characteristics; you can display values for the 
current acquisition or for all acquisitions 

TIE: RjDj – BER* For selected TIE measurements, shows the jitter 
decomposition and the eye opening at the selected BER; 
two sets of values display results for the current 
acquisition and for all acquisitions 

Equivalent RjDj*** For selected TIE measurements, shows the jitter values 
according to the equivalent jitter model as defined in the 
Fibre Channel - Methodologies for Jitter and Signal 
Quality Specification - MJSQ document; two sets of values 
display results for the current acquisition and for all 
acquisitions 

* TDSJIT3 v2 Advanced only. 
** To enable, see the Viewing Equivalent RjDj Results topic. 
  

Viewing Equivalent Rj/Dj Results (TDSJIT3 v2 Advanced Only) 

Some standards require that timing jitter be separated into deterministic and 
random categories using a prescribed method called Equivalent Rj/Dj or 
Effective Rj/Dj, This method is described in Section 8 of the Fibre Channel - 
Methodologies for Jitter and Signal Quality Analysis - MJSQ document. This 
analysis makes some simplifying assumptions about the jitter characteristics, in 
an attempt to yield results that are consistent between different types of 
measurement instrumentation. It is known that the assumptions required for this 
analysis method generally result in conservative (overstated) Rj amounts. 

By default, the Equivalent Rj/Dj tab is not enabled in the TDSJIT3 v2 user 
interface, although the measurement is always active and the results are always 
reported through GPIB. To enable the Equivalent Rj/Dj tab in the user interface, 
follow these steps: 
1. Exit the TDSJIT3 v2 application if it is running. 
2. Use a text editor (such as Notepad) to open the "jit3option.ini" file, which 

resides in the C:\Program Files\TekApplications\TDSJIT3v2 directory. 
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3. Locate the line that says "equivalentRjDj=false" and change it to 
"equivalentRjDj=true". If you cannot find the line, add it. 

4. Save the file. 
5. Restart the TDSJIT3 v2 application and take measurements. The application 

displays the Equivalent Rj/Dj tab in the Results menu for TIE measurements. 

Results as Plots 
The application can display the results as 2-dimensional plots for easier analysis. 
Before or after you take measurements, you can select and configure up to four 
plots. The last plot selected displays when the application completes sequencing. 

If you set up plots after sequencing, the application displays the plot based on the 
current measurement and result.  

Note: When taking measurements in the Free Run mode, you must stop the 
sequencing before you can use some plot features.  

Table 29: Plot types 

Plot type Description 
Histogram Represents measurements sorted by value as a distribution of 

measurement values versus the number of times the value 
occurred 

Time Trend Represents the measurement values versus the time location 
Cycle Trend Represents the measurement values versus the index number 

of the measurement 
Spectrum Represents the frequency content computed using the FFT of 

the Time Trend plot 
Bathtub* Represents the Bit Error Rate versus the horizontal eye 

opening for TIE or PLL TIE measurements that include Rj/Dj 
analysis 

Transfer 
Function* 

Represents the magnitude ratio of two spectrums; the plot 
requires two measurements from the following set: Clock 
Period, Clock Frequency, Clock TIE, Clock PLL TIE, Data 
Period, Data Frequency, Data TIE, Data PLL TIE 

Phase Noise* For Clock TIE measurements only, represents the phase noise 
of a clock signal and is plotted in the frequency domain 

* TDSJIT3 v2 Advanced only.  
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Table 30: Measurements and available plots 

 
Histogram

Time 
Trend 

Cycle 
Trend 

 
Spectrum

 
Bathtub* 

Transfer 
Function*** 

 
Phase Noise***

All All All All TIE 
PLL TIE 

Period, 
Frequency 
TIE 
PLL TIE 

Clock TIE 
Clock PLL TIE

* TIE: RjDj analysis options are available in the Configure Meas General menu. 
** TDSJIT3 v2 Advanced only. 
  

Note: TIE and PLL TIE measurements refer to Clock TIE, Clock PLL TIE, Data 
TIE, and Data PLL TIE measurements unless specified.  

Using a Separate Monitor to View Plots 

If your oscilloscope setup includes a second monitor that extends the Windows 
desktop, you can select and drag the title bar of a plot window to position it in the 
second monitor. This allows you to simultaneously display a waveform on the 
oscilloscope, the TDSJIT3 v2 measurement results, and the plot for easy viewing.  

Note: When setting your oscilloscope to include a second monitor, the Number 
of Colors setting for the second monitor must be the same number of colors as 
your oscilloscope. 

Plot Usage 

Histogram Plot Usage 

Histogram plots display the results such that the horizontal axis represents the 
measurement value ranges and the vertical axis represents the number of times 
that the range of values occurred. Unlike most other plots, a histogram plot 
accumulates measurements over multiple acquisitions, up to a total population 
size of 2.0 billion. 

Histograms are particularly useful in analyzing jitter. A histogram of the Time 
Interval Error (TIE) represents the basis of jitter analysis using a histogram 
approach. In a histogram, Deterministic Jitter (Dj) is bounded and shows up as a 
non-gaussian distribution. Random Jitter (Rj) is unbounded and the amplitude 
along the horizontal axis will continue to grow as more population is acquired. 
The TIE histogram is an excellent way to quickly assess jitter visually.  

The vertical scaling (log versus linear) can be changed at any time without losing 
the accumulated statistics. The number of bins can also be changed at any time, 
since 2500 bins are always used for the actual computation. Autoset sets the 
Center and Span appropriately based on the currently accumulated results. 
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Note: Changing any of the horizontal scale controls (Center, Span, Refresh, 
Autoset) will cause the histogram plot to reset so that only the results from the 
most recent acquisition are displayed. This is because the bin size must be 
recalculated. If you change the Center or Span options, you can select the 
Refresh button, or the Run/Stop or Single buttons (to acquire data) to update the 
plot display. 
Time Trend Plot Usage 

A Time Trend plot is a waveform trace of a measurement versus time. This is 
useful, for example, in determining if the embedded clock in a serial bit stream is 
modulated outside the capabilities of your receiver to recover the clock. If the 
TIE time trend plot starts to take an unexpected periodic shape, then this could 
indicate that you have uncorrelated periodic jitter from crosstalk or from power 
supply coupling.  
Cycle Trend Plot Usage 

A Cycle Trend plot shows measurement values versus measurement index, where 
the indexes are always equally spaced along the horizontal axis. In contrast, the 
measurement values on a Time Trend plot are not equally spaced along the 
horizontal time axis. 
Spectrum Plot Usage 

A Spectrum plot is obtained from the Fast Fourier Transform of a Time Trend 
plot. This plot is useful in identifying frequency components that contribute to 
timing errors, such as modulation of the measurements.  

When the signal has a repetitive data pattern, an analysis on the TIE Spectrum of 
the signal can be used to separate Random Jitter (Rj) from Deterministic Jitter 
(Dj) as well as separate Dj components of Periodic Jitter (PJ) and other Dj 
components such as ISI and DCD. The frequency of periodic jitter spikes that do 
not correlate to frequencies contained in the data pattern can be a clue that you 
should look at frequencies of different components in your design as possible 
sources of jitter. 
Bathtub Plot Usage (TDSJIT3 v2 Advanced Only) 

The Bathtub curve plot is a convenient way to visualize how the jitter eye 
opening varies for different bit error rate assumptions. Many communications 
standards call for Total Jitter to be measured at 10-12 BER. The eye opening 
represented by the Bathtub Curve is what is left of the unit interval after the total 
jitter measurement is subtracted.  
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Transfer Function Plot Usage (TDSJIT3 v2_Advanced 
Only) 

A Transfer Function plot shows the magnitude ratio of the spectrums of two 
measurements. In the next equation, X(t) is a jitter measurement at the input of a 
device, and Y(t) is a jitter time trend at the output of the device. The Transfer 
Function plot can be used to show the following function, where X(f) is the 
Fourier Transform of X(t): 

|)(|
|)(|)(

fX
fYfH =

 
The horizontal axis of the Transfer Function plot goes up to the nyquist 
frequency of X or Y, whichever is lower. These plots work best if averaged 
across multiple acquisitions to reduce the effects of measurement noise. 
Phase Noise Plot Usage (TDSJIT3 v2_Advanced Only) 

The Phase Noise plot shows a frequency domain view of the jitter noise on a 
waveform normalized in an industry-standard way. The vertical axis is 
logarithmic and uses the units of dBc/Hz, which means "decibels (relative to the 
carrier) per Hertz." The horizontal axis is logarithmic. In addition to showing the 
phase noise curve, this plot allows the integrated noise between two user-
selectable frequencies to be displayed. 

Creating Plots 

Before or after you take measurements, you can set up plots in the Plots Create 
menu. To create a plot, follow these steps: 
1. Select Plots> Create. View the Plots Create menu.  
2. Select a measurement from the list of available measurements and sources 

shown on the left side.  
3. Select a plot format from the Add Plot buttons. The selected measurement and 

plot type appears in the list of Plots shown on the right side. If results are 
available, the application displays the plot; otherwise the plot will appear after 
a measurement sequence is complete. 

4. Add another plot format for the current measurement, or select a different 
measurement and add plots.  

Note: The Phase Noise plot and Bathtub plot (both in TDSJIT3 v2 Advanced 
only) are only enabled when a TIE-type measurement is chosen. The Bathtub 
plot also requires that the RjDj analysis be enabled in the Configure Meas TIE: 
RjDj menu. 
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Table 31: Plots Create menu options 

Option Description 
List of active 
measurements 

Selects the measurement to plot 

Add Plot buttons Selects the type of plot 
Plots Lists up to four selected plots; use this list to clear plots 
Clear button Clears the selected plot 
Clear All button Clears all plots 
  

  

Figure 44: Plots Create menu 

Configuring Plots 

After you create the plots, you can further configure the axes for each 
measurement and plot combination (except for a Cycle Trend plot). To configure 
a plot, follow these steps: 
1. Select Plot> Vert/Horiz Axis or the Vert/Horiz Axis tab. 
2. Select a measurement in the Plots list of measurements and plot types on the 

left side. This causes the area to the right of the table to display options 
relevant to the selected measurement and plot type. 

3. Configure the plot. The application displays the reconfigured plot. 
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Table 32: Vert/Horiz axis options for a Histogram plot 

Area/option Description 
Vertical Scale  
   Log Depicts the vertical axis in a logarithmic scale 
   Linear Depicts the vertical axis in a linear scale (default) 
   No of Bins Defines resolution by the number of bins into which Span is 

divided: 25, 50, 100, 250 (default), or 500 
Horizontal Scale  
   Center Numerical value for the horizontal center position of the 

Histogram after Refresh 
   Span Numerical value for the total horizontal range of the 

Histogram after Refresh 
   Autoset* Uses the latest results to determine the logical values for 

the Center and Span options if the population of the 
measurement is three or more, and then redraws the plot 

   Refresh* Updates the plot with the latest Center and Span values 
entered 

* Changing the Horizontal Scale causes any accumulated results across multiple 
acquisitions to be lost, and only the results of the most recent acquisition will be 
displayed. 
  

  

Figure 45: Vert/Horiz menu for a Histogram plot 

Table 33: Vert/Horiz axis options for a Time Trend 
plot 

Option Description 
Vector Measurement points connect with straight lines (default) 
Bar Places a vertical bar at the horizontal position of each 

measurement with a height (positive or negative) that represents 
the value of that measurement; a horizontal baseline represents 
the mean value of the Time Trend 
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Figure 46: Vert/Horiz menu for a Time Trend plot 

Table 34: Vert/Horiz axis options for a Spectrum plot 

Area/option Description 
Vertical Scale  
   Log Depicts the vertical axis in a logarithmic scale 
   Linear Depicts the vertical axis in a linear scale (default) 
   Baseline Numeric value (expressed as a base-10 exponent) at the 

bottom of a logarithmic vertical scale 
Horizontal Scale  
   Log Depicts the horizontal axis in a logarithmic scale 
   Linear Depicts the horizontal axis in a linear scale (default) 
   Mode Selects whether the plot shows only the most recent 

spectrum, the uniform average of all spectrums since the 
last time the results were cleared, or the peak of the 
envelope of all spectrums since the last time the results 
were cleared 
Normal updates the plot with current values (default) 
Average averages the magnitude values at each frequency 
Peak Hold keeps the maximum value at each frequency 

  

  

Figure 47: Vert/Horiz menu for a Spectrum plot 
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Table 35: Vert/Horiz axis options for a Bathtub plot 

Option Description 
Linear Depicts the vertical axis in a linear scale  
Log Depicts the vertical axis in a logarithmic scale (default) 
Minimum Displayed 
BER=1E-? 

Numeric value (expressed as the negative of a base-10 
exponent) at the bottom of the logarithmic vertical scale; 
default = 12, representing 10-12 

  

  

Figure 48: Vert/Horiz menu for a Bathtub plot 

Transfer Function Definition Options 

The Transfer Function plot requires two measurements from the following set: 
Clock Period, Clock Frequency, Clock TIE, Clock PLL TIE, Data Period, Data 
Frequency, Data TIE, and Data PLL TIE.  

Table 36: Transfer Function Definition configuration 

Option Description 
Numerator Measurement for which the magnitude spectrum is used as a 

reference 
Denominator Measurement for which the magnitude spectrum is used to 

normalize the numerator 
Invert Swaps the measurements used as the Numerator and as the 

Denominator 
OK Accepts changes and closes 
Cancel Discards changes and closes 
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Transfer Function Definition Menu 

  

Figure 49: Transfer Function Definition options 

Table 37: Vert/Horiz axis options for a Transfer 
Function plot 

Area/option Description 
Vertical Scale  
   Log Depicts the vertical axis in a logarithmic scale (default) 
   Linear Depicts the vertical axis in a linear scale  
Horizontal Scale  
   Log Depicts the horizontal axis in a logarithmic scale (default) 
   Linear Depicts the horizontal axis in a linear scale  
   Mode Selects whether the plot shows only the most recent 

spectrum, or the uniform average of all spectrums since the 
last time the results were cleared (default) 
Normal updates the plot with current values 
Average averages the magnitude values at each frequency 

Function Def 
   Invert 

Swaps the measurements used as the Numerator and as 
the Denominator; resets any averaging to include only the 
most recent acquisition 
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Figure 50: Vert/Horiz menu for a Transfer Function 
plot 

Table 38: Vert/Horiz axis options for a Phase Noise 
plot 

Area/option Description 
Vertical Position  
   Baseline Numeric value at the bottom of a logarithmic vertical scale 
Integrated Noise  
   Lower Limit Sets the lower frequency limit over which noise will be 

integrated 
   Upper Limit Sets the upper frequency limit over which noise will be 

integrated 
   RMS Displays the RMS value of integrated noise between the 

lower and upper limits. 
  

  

Figure 51: Vert/Horiz menu for a Phase Noise plot 
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Working with Plots 
You can create and configure up to four plots. By default, all four plot windows 
are overlayed on the upper half of the display, but each window can be moved, 
resized, or dragged to a second monitor. The application includes tools to help 
you select which plots to view, to size and position the plot windows, to save plot 
information, to use the zoom function, and to use the cursors functions.  

If your Windows desktop is extended to a second monitor, you can drag the plots 
window to the second monitor. 

Note: When sequencing is complete, the plot window displays with the last plot 
selected. The plot window also updates whenever you reconfigure a plot. 

Toolbar Functions in Plot Windows 

Each plot window includes the following tool groups: 

•  to save the plot contents to a file (data or image) or to export to a 
reference memory location on the oscilloscope 

•  to position the plot window in default positions and sizes when 
the window is displayed on the oscilloscope 

•  to place a selected plot in the foreground in one of the two default 
positions 

•  to select between the Zoom tools or the Cursors tools 

•  to use the Zoom tools 

•  to use the Cursor tools 
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Selecting and Viewing a Plot 

To select and view an existing plot, follow these steps: 

1. Select the  button. The Locate Window At dialog box appears.  

  

Figure 52: Locate Window At options 

The Select View button appears on the Control Panel and in the toolbar of 
every plot window.  

2. To view the first plot in the Active Plots Summary table on the top half of the 
display, select the Plot1 button from the Top column. To view this plot on the 
bottom half of the display, select Plot1 from the Bottom column. 
You can place the other defined plots on the top or bottom of the display by 
similar steps. Select the Scope button to bring the oscilloscope interface to the 
top of the display. Select the App button to bring the TDSJIT3 v2 main 
window to the bottom. 

3. Select Close or  to dismiss the Locate Window At dialog. This dialog must 
be dismissed before the TDSJIT3 v2 windows will respond to any other 
commands. 

 If you have a keyboard, you can use the Alt-Tab Window shortcut to 
quickly select a window for viewing. 

 If you have a second monitor, you can select and drag the title bar of a plot 
window to position it in the other monitor. 

Moving and Resizing a Plot 

You can move and resize plot windows the same way you would move and resize 
any window. 

The plot position tools can move a plot to the upper or lower half of the 
oscilloscope display. The tools also return the plot to the original size. To 
position a plot quickly on the oscilloscope, select one of the following tools in 
the plot window: 

•  positions the plot in the upper half  
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•  positions the plot in the lower half 

Deleting Plots 

You can remove individual or all selected plots. To remove an individual plot, 
follow these steps: 
1. Select Plots> Create or the Create tab.  
2. Select the plot to be removed in the list of Plots on the right side.  

3. Select the  button.  

To remove all selected plots, select the  button. 

The plot window updates and removes the deselected plot from the display.  

Using Zoom in a Plot 

Once you have created a plot, you can use the Zoom tools to examine the data at 
various scales. You can use the buttons in the Zoom toolbar to do the following 
tasks: 

•  to examine a small portion of a waveform in greater detail 

•  see the a larger portion of the waveform 

•  to see the entire available waveform 

•  for Time Trend plots, to synchronize the zoom window of the 
oscilloscope with the zoom window of the TDSJIT3 v2 application  

 If you prefer to use the zoom functions in a plot window with your finger, 
you can activate the Touch Screen on the oscilloscope provided the model you 
are using has this feature. 
Zooming In 

To examine a portion of the waveform in greater detail, follow these steps: 

1. In the  Control tools, select the  button. This step is 
not necessary if the Zoom toolbar is already visible. 

2. In the Zoom toolbar, select the  button. 
3. To zoom the horizontal scale by a factor of two without affecting the vertical 

scale, click-and-release on a point of interest in the waveform.  
4. To zoom in by an arbitrary amount both horizontally and vertically, use a 

click-drag-release action with the mouse. After you click and begin dragging, 
a bounding box will appear to show what part of the waveform will be 
expanded upon release. 

The two zoom methods may be repeated in any order until the maximum zoom is 
reached. 
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Zooming Out 

To reduce the scale of a plotted waveform so that more of the waveform can be 
seen, follow these steps: 

1. In the  Control tools, select the  button. This step is 
not necessary if the Zoom toolbar is already visible. 

2. To zoom out partially, select the  button in the Zoom toolbar and then 
click anywhere on the waveform. The view is restored to the zoom values that 
existed before the most recent zoom-in. Clicking multiple times will restore 
successively earlier views. 

3. To zoom out completely, select the  button. The view will be restored to 
its initial zoom settings, in which the entire waveform can be seen. 

Using Zoom Sync (Time Trend Only) 

By using the Zoom Sync function, you can synchronize the zoom window of the 
oscilloscope with the current horizontal axis limits of a Time Trend plot. To do 
so, follow these steps: 
1. Create, configure, and display a Time Trend plot. 

2. In the  Control tools, select the  button. This step is 
not necessary if the Zoom toolbar is already visible. 

3. Use the zoom tools until the desired portion of the Time Trend waveform is 
visible. 

4. Select the  button. This turns on the zoom mode on the oscilloscope, and 
adjusts the horizontal zoom scale and position to correspond closely with 
those of the Time Trend plot. 

Note: Selecting the Sync button will not bring the oscilloscope user interface to 
the foreground if it is obscured by a plot window. To make the oscilloscope 
visible, use the Select View button or the Windows Alt-Tab shortcut.  

Since the zoom window of the oscilloscope has a limited number of valid scale 
factors, the time scale synchronization is not necessarily an exact match. 

Using Cursors in a Plot 

Cursors allow you to view numerical values associated with a plot based on 
cursor locations. There are two cursor modes: Vertical-paired and Horizontal-
paired. Each mode displays two cursors in a plot.  

Note: You can only use one mode at a time; vertical or horizontal-paired but not 
both. 

You can use the buttons in the Cursor toolbar to do the following tasks: 

•  to display the horizontal coordinate where each cursor touches the plot 
and the difference (delta) between the cursors  
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•  to display the vertical coordinate where each cursor touches the plot and 
the difference (delta) between the cursors  

•  to position cursors on minimum and maximum values 

•  for Time Trend plots, to synchronize the oscilloscope cursors with the 
position of the plot cursors 

•  to remove cursors from the display 

 The most precise way to move the cursors in a plot window is with the 
Multipurpose knobs of the oscilloscope provided the cursors are associated with 
the Multipurpose knobs (focused).  
Focusing Cursors 

The cursors do not always become focused (associated with the Multipurpose 
knob) when you select a plot window. Sometimes the application can lose focus 
of the cursors if you switch windows, switch cursors when using both, use the 
Min/Max button, or use the Sync cursors between a Time Trend plot and the 
oscilloscope and then move the oscilloscope cursors. 

To focus the cursors, select the cursor in the plot window. 
Using Vertical Cursors in a Plot 

Vertical cursors appear as two vertical lines in a plot window. They enable you to 
read the horizontal coordinates where each line touches the plot and also view the 
horizontal difference (delta) between the two cursors. 

In addition, a red cross appears where each cursor intersects the plotted 
waveform. The vertical value at each of these crosses (as well as the vertical 
delta) is shown in the plot window. 

To use Vertical cursors while viewing a plot, follow these steps: 

1. In the Control tools, select the  button.  

2. In the Cursor tools, select the  button. 
3. Select and drag either cursor line, or use the Multipurpose knobs on the 

oscilloscope to move the cursor to the part of the plot desired. 

The cursor readout changes value to reflect the cursor position.  

 If you prefer to move the cursors in the plot window with your finger, you 
can activate the Touch Screen on the oscilloscope provided the model you are 
using has this feature. 

Note: You can drag cursors only when the Zoom functions are disabled. 

 The most precise way to move the cursors in the plot window is with the 
Multipurpose knobs of the oscilloscope provided the cursors are associated with 
the Multipurpose knobs (focused).  
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 Use the  button to place the Vertical cursors at the levels 
corresponding to the minimum and maximum values within the currently 
displayed horizontal extent of the plot. 
Additional Ways to Use Vertical Cursors 

You can also use the Vertical Cursors in the following ways: 

• Use the  button to place the two cursors at the positions corresponding 
to the minimum and maximum vertical values within the plot. If the plot 
display has been zoomed, the minimum and maximum values within the 
current horizontal limits of the zoom are used. 

• For Time Trend only, you can use the  button to synchronize the 
oscilloscope cursors with the plot cursors’ positions. 

• Min/Max is most useful for Trend Plots. The Max (half of the feature) is 
useful for Spectrum plots. 

Using Horizontal Cursors in a Plot 

Horizontal cursors appear as two horizontal lines in a plot window. They enable 
you to read the vertical coordinates where each line touches the plot and also 
view the horizontal difference (delta) between the two cursors. 

To use Horizontal cursors while viewing a plot, follow these steps: 

1. In the Control tools, select the  button.  

2. In the Cursor tools, select the  button. 
3. Select and drag either cursor line, or use the Multipurpose knobs on the 

oscilloscope to move the cursor to the part of the plot desired. 

The cursor readout changes value to reflect the cursor position.  

 If you prefer to move the cursors in the plot window with your finger, you 
can activate the Touch Screen on the oscilloscope provided the model you are 
using has this feature. 

Note: You can drag cursors only when the Zoom functions are disabled. 

 The most precise way to move the cursors in the plot window is with the 
Multipurpose knobs of the oscilloscope provided the cursors are associated with 
the Multipurpose knobs (focused).  

 Use the  button to place the Horizontal cursors at the levels 
corresponding to the minimum and maximum values of the visible portion of the 
plot. 
Using Cursors Sync (Time Trend Only) 

You can select the Sync button to synchronize the oscilloscope cursors with those 
in a Time Trend plot. 
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Using Min/Max Cursors 

You can select the Min/Max button to position cursors to the maximum and 
minimum values as appropriate horizontally or vertically. 

Min/Max cursors are most useful for Time Trend plots. The Max (half of the 
feature) is useful for Spectrum plots. 
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Exporting Plot Files 

There are several ways you can export plot information from the TDSJIT3 v2 
application for use in other applications:  
• You can export the mathematical data that is represented in the plot figure. 

This may be useful if you wish to perform additional processing on the data. 
• You can create an image file that captures the current plot view. This may be a 

useful way to document your results. 
• You can export a plot to a reference memory location in the oscilloscope. This 

may be useful if you want to use math expressions in the oscilloscope to 
further process the measured data. 

The  tool offers the following choices from the Save drop-
down list: 
• Data saves the numerical values from the plot window in text or MATLAB 

format  
• Fig saves the contents of the plot window as an image file 
• Ref saves the plot in an oscilloscope reference memory location (Ref1, Ref2, 

Ref3, or Ref4) 

Note: Export plot functions are disabled whenever the application is actively 
sequencing. 
Exporting Raw Plot Data 

The waveform image in each plot is typically only 500 by 160 pixels, but the data 
that it represents may be several million samples of double-precision floating-
point information. Exporting this data allows you to perform addition processing 
or derive custom measurements. 

Note: The TDSJIT3 v2 application can produce files that are too large for most 
spreadsheet programs to load completely. However, you can still use a text editor 
to view the entire file. 

To export the mathematical data that was used to create a plot, follow these steps: 
1. Select Data as the Export tool in the upper left corner of the plot window. A 

file chooser window appears.  
By default, the chooser provides a filename derived from the current date and 
time, and offers to place the data in a folder called "plotData" in the TDSJIT3 
v2 file area. The default data type is ASCII text. 

2. Use the controls at the top of the file chooser to select the directory where you 
would like to save the data. 

3. If ASCII text is not the desired data format, use the drop-down list labeled 
"Files of type:" to select another file type. The choices are: 

• ASCII Text (.txt) – ASCII text that is readable by an editor such as 
Wordpad 
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• Comma Separated Values (.csv) – ASCII text that can be loaded into a 
spreadsheet 

• MATLAB (.mat) – Binary data in the native MATLAB 5.0 format 

 Binary files typically use about 40% as much disk space as text files. 

4. If you have a keyboard, you can change the filename. 

5. Select Save to save the data. 

Note: Files with .txt and .csv extensions are identical except for the extension. 
Exporting Plot Images 

You can save the exact waveform that you see in the plot window, including any 
cursors. This may be convenient for reports, engineering records, or sharing 
interesting results with your peers.  

To create an image file from your plot, follow these steps: 
1. Adjust the zoom and/or cursors to get the view you wish to save. 
2. Select Fig as the Export tool in the upper left corner of the plot window. A file 

chooser window appears.  
By default, the chooser provides a filename derived from the current date and 
time, and offers to place the image file in a folder called "plotFigure" in the 
TDSJIT3 v2 file area. The default image format is Portable Network Graphics 
(.png). 

3. Use the controls at the top of the file chooser to select the directory where you 
would like to save the image. 

4. If PNG is not the desired image format, use the drop-down list labeled "Files 
of type:" to select another format. The choices are: 

• Windows Bitmap (.bmp) – Uncompressed pixel map in the standard 
Windows format  

• JPEG File Interchange Format (.jpg) – A lossy, compressed format  

• Portable Network Graphics (.png) – A lossless, compressed format that 
offers good portability  

5. If you have a keyboard, you can change the filename. 
6. Select Save to save the data. 
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Exporting a Plot to a Reference Memory Location 

You can transfer the plot to a reference memory location on the oscilloscope, and 
then save it as a .wfm file. To do so, follow these steps: 
1. Select Ref as the Export tool in the upper left corner of the plot window. 
2. Select the desired Ref and then OK. 
3. Use the export function of the oscilloscope to save the plot in the reference 

memory location to the hard disk as a .wfm file. 

Saving Information to Log Files 
The application includes the following Log menus: 
• Statistics  
• Measurements  
• Worst Case Waveforms  
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Logging Statistics 

The application can continuously log (save to file) the calculated statistics, or 
save a snapshot of the current statistics. You can save the statistics to a "comma 
separated value" (.csv) file to import into a text editor, a spreadsheet, or an 
analysis tool. 

Note: The TDSJIT3 v2 application can produce .csv files that are too large for 
most spreadsheet programs to load completely. However, you can still use a text 
editor to view the entire file. 

By default, all actual measurements are selected. You can select individual 
measurements by selecting the measurement number or row in the table on the 
left side of the menu. 

To log statistics to a file, follow these steps: 
1. Select Log> Statistics. The Log Statistics menu appears.  
2. Select measurements that you want to log in the table on the left of the menu 

or choose the "Yes to All" button. You can also choose "No to All" to clear 
the current selection list.  

3. To log statistics continuously, select the  button. The Log File Name 
menu appears. The default directory is C:\TekApplications\TDSJIT3v2\log. 

4. Select an existing file or a new file to contain the saved statistics for all 
selected measurements. 

5. Select the  button. The file name menu closes. 
6. To stop logging, select the Off button or the Delete button to delete the current 

statistics file. 
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To save a snapshot of current statistics (as shown in the Results menu), under 
Save Current Statistics, select the Save button to save the current statistics to a 
statsSnapshot.csv file. The default directory is 
C:\TekApplications\TDSJIT3v2\log.  

Note: For either type of logging, you can use the Delete button to browse and 
delete files. 

Table 39: Log Statistics configuration 

Option/button Description 
Log Statistics Enables the application to continuously save the statistical 

results for all selected measurements  
   On button Browse to select or enter a file name and enable logging 
   Off button Disable continuous logging 
   Delete button Browse to select and delete .csv files 
Save Current 
Statistics 

Saves a snapshot of the current statistics for the current 
acquisition and accumulated acquisitions for selected 
measurements 

   Save button Browse to select a file name and save a Snapshot of 
statistics 

   Delete button Browse to select and delete .csv files 
  

Logging Measurements 

You can log the actual data points as measurement files. You can log data points 
continuously or save the data points for the current acquisition. You can save the 
data points to a "comma separated value" (.csv) file to import into a text editor, a 
spreadsheet, or an analysis tool. 

Note: The TDSJIT3 v2 application can produce .csv files that are too large for 
most spreadsheet programs to load completely. However, you can still use a text 
editor to view the entire file. 

To log measurements, follow these steps: 
1. Select Log> Measurements> Configure. The Log Measurements menu 

appears.  
2. Select measurements that you want to log or choose the "Yes to All" button. 

(You can also choose "No to All" to clear the current selection list.) 

3. To log measurements continuously, select the  button. The Choose 
Log Measurement Directory menu appears.  

4. Select a directory to contain the saved measurement files (one file for each 
measurement). 

5. Select the OK button. The Choose Log Measurement Directory menu closes. 
6. To stop logging, select the Off button. 
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To save current data points in measurement log files, under Save Current 
Measurements, select the Save button to browse for a directory and to save a 
snapshot of the data points to a file for each selected measurement. 

Note: For either type of logging, you can use the Delete button to browse and 
delete individual measurement files. Using either log measurement feature 
provides a directory browser to navigate or create new folders. 

Table 40: Log Measurements configuration 

Option/button Description 
Log Measurements Enables the application to save all selected 

measurements  
   On button Browse to select or enter a directory name and turn on 

logging 
   Off button Turn off continuous logging 
   Delete button Browse to select and delete .csv files 
Save Current 
Measurements 

Saves a snapshot of the current measurements for the 
current acquisition and accumulated acquisitions for 
selected measurements 

   Save button Save current and accumulated measurements 
   Delete button Browse to select and delete .csv files 
  
File Names for Logging Measurement Files 

The application automatically names the files for you based on a combination of 
the measurement name and source used. You can select the File Names tab to see 
the file names created by the application.  

You can also choose a directory for measurement log files.  



 Operating Basics 

TDSJIT3 v2 Jitter Analysis Online Help 

 

77

Logging Worst Case Waveforms 

You can use the Log Worst Case menus to save the acquired waveforms 
whenever a selected measurement exceeds the highest or lowest prior value. 
When enabled, the waveforms are saved to a set of .wfm files including the 
qualify waveform if active. 

To log worst case waveforms, follow these steps: 
1. Select Log> Worst Case> Configure. 
2. Select measurements for which you want to log the worst case waveforms, or 

choose the "Yes to All" button. (You can also choose "No to All" to clear the 
current selection list.)  

3. To log worse case waveforms continuously, select the  button. The 
Log Worst Case Waveforms menu appears.  

4. Select a directory to contain the saved waveforms. 
5. Select the OK button. The Log Worst Case Waveforms menu closes. 
6. To stop logging, select the Off button. 

Note: Use the Delete button to delete all the .wfm files in the selected directory. 

Table 41: Log Worst Case Waveforms configuration 

Option/button Description 
Log Worst Case 
Waveforms 

Enables the application to save worst case waveforms for 
all selected measurements  

   On button Browse to select or enter a directory name and turn on 
logging 

   Off button Turn off continuous logging 
   Delete button Browse to select and delete .wfm files 
  

File Names for Logging Worst Case Waveforms  

The application automatically names the files for you based on a combination of 
the following information: 
• Measurement name 
• Source of the waveform, such as Ch1  
• Whether the file is a maximum or minimum value waveform 

You can select the File Names tab to see the file names created by the 
application. 

If a qualify waveform is saved, the file name will include the following 
information: 
• QUAL to identify it as a qualify waveform if active 
• Source of the waveform, such as Ch2  
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Saving and Recalling Setup Files 
You can use the File menus to save and recall different application setups and 
recently accessed files.  

 Do not edit a setup file or recall a file not generated by the application. 

Saving a Setup File 

To save the application and oscilloscope settings to a setup file, follow these 
steps: 
1. Select File> Save. The Save dialog box appears. View the Save browser.  
2. In the file browser, select the directory in which to save the setup file or use 

the current directory. 
3. To view details about existing files, such as size, type, and date modified, 

select the Details tool. 
4. Use the keyboard to enter a new file name.  

The application appends an ".ini" extension to the name of the application 
setup file. 

5. Select the  command button. If the selected filename already 
exists, a confirmation dialog appears that allows you to cancel the operation. 



 Operating Basics 

TDSJIT3 v2 Jitter Analysis Online Help 

 

79

Note: The application also saves the oscilloscope setup to a ".set" file when you 
save an application setup. Both the application .ini file and oscilloscope .set file 
have the same file name. 

To view details, such as file size, type, and date modified, select the  Details 
tool. 

  

Figure 53: File Save browser 
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Recalling a Saved Setup File 

To recall the application and oscilloscope settings from saved setup files, follow 
these steps: 
1. Select File> Recall. The Recall dialog box appears. View the Recall browser.  
2. In the Recall dialog box, select the directory from which to recall the setup 

file.  

To view details about the files in the directory, such as size, type, and date 
modified, select the Details tool.  
3. Select a setup file name, and then select Open. 

Note: The application recalls the .ini setup file and the associated oscilloscope 
setup if the application can find a .set file with a matching name.  

 Do not edit setup files. If you try to recall a setup file that has been edited, 
the recall operation fails. 

 If a matching .set file is not found or if the .set file does not recall correctly 
to the oscilloscope, then a warning appears that says that the oscilloscope recall 
failed while the TDSJIT3 v2 application recall succeeded. 

To view details, such as file size, type, and date modified, select the  Details 
tool. 

  

Figure 54: File Recall browser 
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Recalling the Default Setup 

To recall the default application settings, select File> Default Setup. Most of the 
menu options are set to the same values or selections as when you launch the 
application. 

Recalling a Recently Saved or Accessed Setup File 

To recall a recently saved or accessed setup file, select File> Recent Files and 
then the file from the drop down list of setup file names. 

Note: The application also recalls the associated oscilloscope setup if the 
application can find a .set file with a matching name.  

 Do not edit setup files. If you try to recall a setup file that has been edited, 
the recall operation fails. 

 If a matching .set file is not found or if the .set file does not recall correctly 
to the oscilloscope, then a warning appears that says that the oscilloscope recall 
failed while the TDSJIT3 v2 application recall succeeded. 

 

Recall Recent Files Example 

  

Figure 55: Recall Recent files example 

Recalling a Setup File from a Earlier Version of Software 

Setup files that were saved using a prior version of the TDSJIT3 application may 
be recalled. For those features that were not present in the prior version, 
reasonable default settings are used. You may wish to verify that settings not 
specified by the old file are acceptable. 

Note: Setup files from previous versions may include directory paths such as 
"C:\TekApplications\TDSJIT3\...", whereas the v2 application defaults to 
"C:\TekApplications\TDSJIT3v2\...". If you would like your converted setup 
files to use the TDSJITv2 directory, recall the existing setup file, use the 
Graphical User Interface to change any file paths to use the new directory 
structure, and then save the setup. 

After you recall the setup file, you may save the setup again to create a setup file 
with the latest format. Use a different filename if you wish to retain the old setup 
file. 

Vertical reference levels receive special attention during setup file conversion. If 
all of the reference levels for an active source are the default values (where High 
is set to 1.0 V, Mid is set to 0.0 V, Low is set to -1.0 V, and the Hysteresis is set 
to 0.03 V), then that source shall be configured for Automatic reference levels. 
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Otherwise, the source shall be configured for Manual reference level and the 
reference levels in the setup shall be used exactly as they are. For more 
information, see the Automatic Versus Manual Reference Voltage Levels topic. 

Some prior versions of the TDSJIT3 application used a configuration file 
("jit3option.ini") to establish the order of the phase-locked loop used for clock 
recovery in PLL TIE measurements. The current TDSJIT3 application includes 
these controls and ignores the loop-order settings in the older configuration file. 
You can set these values manually, if necessary, and save a new setup file. After 
this, you can use the new setup file to ensure that the PLL settings are properly 
set. 

Note: Setup files from the TDSJIT2 application are not supported. 

Docking and Undocking the Jitter Analysis Window 

The Dock function positions and locks the TDSJIT3 v2 application in the lower 
half of the oscilloscope display and the oscilloscope application in the upper half 
of the display. 

The Undock function unlocks the window and allows you to move the 
application to another position in the oscilloscope display or drag it to a second 
monitor; the oscilloscope display returns to full size. 

The Dock and Undock functions are available under the File menus in the menu 
bar. 

Acquisition Timeout Utility 

The Acq Timeout utility sets the delay (in seconds) that the application allows 
between an acquisition start and when a waveform is expected.  
• Auto allows the application to adjust the delay according to the record length 

and measurement complexity 
• User allows you to set the appropriate delay value from 30 seconds to 24 

hours (86400 seconds) in 30 second increments 

 

Figure 56: Acquisition Timeout options 
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Warnings Utility 

The Warnings utility lists errors that have occurred and a brief description of 
each. To clear the contents from the file, select the Clear button. 

Warnings are also designated with a yellow  icon and errors with a red  
icon in the status bar along the bottom of the TDSJIT3 v2 application window. 
Once a message appears in the status bar, you can dismiss it by selecting the 
View Log button in the status bar, or by selecting the Clear results button. 
Neither action removes the message from the warnings log file. 
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Tutorial 

The purpose of this tutorial is to familiarize you with the basic functions of the 
TDSJIT3 v2 application and menus. This tutorial teaches you how to do the 
following basic tasks:  
• Set up the application  
• Take two types of measurements 
• View the results as statistics and as plots 

Before you begin the tutorial, you must do the following tasks: 
• Set up the oscilloscope  
• Start the application  
• Recall the tutorial waveform  

Note: The screen captures shown are from a TDS7000 oscilloscope; there may 
be minor differences in the screens from other oscilloscope models. 

Setting Up the Oscilloscope 
To set up the oscilloscope, follow these steps: 
1. In the oscilloscope menu bar, select File> Recall Default Setup to set the 

oscilloscope to the default factory settings. 
2. Press the individual CH1, CH2, CH3, and CH4 buttons as needed to remove 

active waveforms from the display. 

Starting the Application 

The way you start the application depends on the oscilloscope model. To start the 
application, do one of the following:  

• Select App > Jitter Analysis – Advanced 

• Select File > Run Application > Jitter Analysis – Advanced in the 
oscilloscope menu bar 

• Select Analyze > Jitter Analysis – Advanced 

If you are using the TDSJIT3 v2 Essentials application, select Jitter Analysis - 
Essentials.  

If the Jitter Wizard displays, select the Cancel button. 

Waveform Files 

The application includes two waveform files to use with this tutorial:  
• j3clk1.wfm (clock signal)  
• j3dat1.wfm (data signal)  
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Recalling a Waveform File 

The way you recall a waveform to reference memory depends on the oscilloscope 
model. 

To recall a waveform file on most oscilloscopes, follow these steps: 
1. In the oscilloscope menu bar, select File> Reference Waveforms> Reference 

Setup, File> Reference Waveform Controls, or File> Recall. If the 
oscilloscope is in the Button mode, select the Ref or Recall button. 
Ref1 is the default memory location to recall a waveform file. View the 
Oscilloscope Reference Memory Setup menu.  

2. Select the  button for Recall Ref1 from File.  
3. Navigate to the C:\TekApplications\TDSJIT3v2\Examples\waveforms 

directory. 

4. Select the j3clk1.wfm file, and then the  button. 
The oscilloscope recalls the waveform file to reference memory and displays 
the waveform when the recall is complete. 

5. The way you return to the application depends on the oscilloscope model. To 
return to the application, in the oscilloscope menu bar, select App> Restore 

Application or select the  button. View how to return to the 
application.  

To recall a waveform file on TDS5000B oscilloscopes, follow these steps: 
1. Select File> Recall. The Recall dialog box appears. 
2. In the left side of the dialog box, select the Waveform icon. 
3. Select Ref1, Ref2, Ref3, or Ref4 as the Destination option. 
4. Browse to select the waveform to recall. 
5. Select the Recall button. The oscilloscope recalls and activates the Reference 

Waveform control window. 
6. Select On to display the waveform. 
7. Return to the application. 

Note: The screen capture is from a TDS7000 oscilloscope. There are differences 
in the menu on other oscilloscope models. 
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Figure 57: Oscilloscope Reference Memory options 

 

Taking a Clock Period Measurement 
In this lesson, you will learn how to use the application to take a Clock Period 
measurement and view the results. This lesson teaches you how to do the 
following tasks: 
• Select a waveform source, and then a measurement 
• Configure a measurement 
• Take measurements 
• View the measurement results as statistics 
• View the results as various plots, such as Histogram 
• Stop the application 
• Return to the application 

To perform these lessons, the application must be installed and enabled on the 
oscilloscope. See Installation.  

Setting Up a Period Measurement 

To set up the application to take a Clock Period measurement, follow these steps: 
1. To set the TDSJIT3 v2 application to default values, select File> Default 

Setup. This is not necessary if you just started the application. 
If you just started the application and the Jitter Wizard displays, select the 
Cancel button.  

2. If necessary, select Measurements> Select> Clock. The Measurement Select 
menu appears with the Clock measurement buttons in the Add Measurement 
area. 

3. Select Ref1 from the pop-up list of Select Source Clock options.  
4. Select the Period button in the Add Measurement area. The application shows 

the selection in the Measurement and Sources area on the right side of the 
display. View the Measurements Select menu.  
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5. Select the  button. This lesson uses these default settings. View the 
Configure Measurement menu.  

6. Select the  button, and then the Ref Levels tab. The Measurements 
Configure Source Ref Levels Menu appears.  

7. Select the  command button. The application automatically calculates 
the appropriate reference voltage level values. View the reference voltage 
level values as calculated by the application.  

Note: Step 7 is optional. The application automatically updates the reference 
voltage levels for sources where the Autoset option is set when you start 
sequencing the oscilloscope to take measurements. The Update step is included 
to show you what levels are selected in this lesson. 

  

Figure 58: Clock Period measurement selected 

  

Figure 59: Configuration of a Period measurement 
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Figure 60: Configure Sources Ref Levels before an 
Autoset 

  

Figure 61: Configure Sources Ref Levels after an 
autoset 

Taking a Period Measurement and Viewing Statistical Results 

To take Clock Period measurements and view the results as statistics, follow 
these steps:  

1. Select the  button. The All Statistics Results menu and the Control 
Panel appear. 

2. Select the  Single command button in the Control Panel. 
The application displays the results as statistics. View the results of a Clock 
Period measurement.  
One-by-one, select the other statistical results tabs. View the Min/Max and 
Mean/Std. Dev. the statistical results menus. 

Note: The TIE: RjDj - BER tab is for TDSJIT3 v2 Advanced only. 
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Figure 62: Statistical results for a Clock Period 
measurement 

  

Figure 63: Min/Max statistical results for a Clock 
Period measurement 

  

Figure 64: Mean/Std. Dev statistical results for a 
Clock Period measurement 

Viewing a Period Measurement as Plots 

To view the results as a plot, follow these steps:  
1. Select Plot> Create. View the Plot Create menu.  
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2. Select the  button. The application displays the results as a 
Histogram plot in the upper half of the screen. View the results as a Histogram 
plot.  

3. One-by-one, select other plot menu buttons, such as the , or 

 buttons. View the results as a Time Trend plot, or a Spectrum plot.  

  

Figure 65: Create plots of results 

  

Figure 66: Results as a Histogram plot 
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Figure 67: Results as a Time Trend plot 

  

Figure 68: Results as a Spectrum plot 

Ending a Tutorial Lesson 
If you need more than one session to complete the tutorial lessons, you can stop 
the tutorial and return to it another time. 

Note: The purpose of this tutorial is to familiarize you with the basic functions of 
the application and menus. 

To save the application setup and stop your session, refer to Saving a Setup File 
and to Exiting the Application. 

To return to the tutorial setup, you can start the application, and then recall the 
saved setup. To recall the application setup, refer to Recalling a Saved Setup File. 

Taking a Clock-to-Output Time Measurement 
In this lesson, you will learn how to use the application to take a Clock-to-Output 
Time measurement. This lesson teaches you how to do the following tasks:  
• Set up and take a Clock-to-Output Time measurement (requires two 

waveforms) 
• View summaries of the measurement setup 
• Log statistical results to a .csv file 
• View a .csv file in a spreadsheet program 
• Log data points for a snapshot of the measurement to a .csv file 
• Log worst case waveforms to .wfm files 

Setting Up and Taking a Clock-to-Output Time Measurement 

To set up and take a Clock-to-Output Time measurement, follow these steps: 
1. Recall the j3dat1.wfm file to the Ref2 memory location in the oscilloscope. 

Refer to the Recalling a Waveform File topic except select the Ref2 tab and 
then recall the waveform. 

The j3clk1.wfm file is already recalled to Ref1 from the previous lesson. 
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2. Return to the application.  
3. Select Measurements> Select> Clk-Data.  

4. Select the  button to remove all the measurements. 
5. Select Ref1 as the Clock Source and Ref2 as the Data Source.  
6. Select the Clock-Out button. View the Measurements Select menu.  

7. Select the  button. This lesson uses these default settings. View the 
Configure Measurement menu.  

8. Select the  button. 

9. Select the  button. View the results of a Clock-to-Output Time 
measurement as statistics.  
The application automatically updates the reference voltage levels for sources 
where the Autoset option is set when you start sequencing the oscilloscope to 
take measurements. 

10. To see the calculated Ref2 values, select Measurements> Configure Sources> 
Ref Levels and then the Ref2 Source button in the Source table. View the 
Configure Source Ref Levels menu.  

11. You can view various summary menus that show measurement settings. To do 
so, select Measurements> Summary of> Measurements. View the summary 
menu.  

12. Select each of the other measurement summary menu tabs. View the summary 
of the reference voltage levels.   

  

Figure 69: Clock-to-Output measurement selected 
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Figure 70: Configuration of a Clock-to-Output 
measurement 

  

Figure 71: Statistical results for a Clock-to-Output 
measurement 

  

Figure 72: Configure Sources Ref Levels for a Clock-
to-Output measurement 
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Figure 73: Measurements Summary for a Clock-to-Output 
measurement 

  

Figure 74: Ref Levels Summary for a Clock-to-Output 
measurement 

Logging Statistics to a .CSV File 

To log statistics to a .csv file, follow these steps: 
1. Select Log> Statistics. The Log Statistics menu appears.  

2. Select the  button. The Log File Name dialog appears.  
3. Select a unique file name that is not listed in the browser window to start a 

new file, such as appending your initials to the stats.csv file name. This 
ensures that the file is empty when logging starts. 

4. Select the  button. The file name menu closes and the Log 
Statistics function is enabled. 

5. Select any menu from the Results drop down list to access the Control Panel. 

6. Select the  button.  
7. Launch the Windows Explorer.  
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8. Navigate to the stats<your initials>.csv file. View the path to the log statistics 
file.  

9. Copy the file, and move it to a PC where you can open it with a spreadsheet 
program. View the stats.csv file in a spreadsheet program.  

  

Figure 75: Log Statistics for a Clock-to-Output 
measurement 

  

Figure 76: Log File Name dialog 
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Figure 77: Path to the stats.csv log file 

  

Figure 78: Viewing statistics in a spreadsheet program 
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Logging Data Points as a Measurement Snapshot to a .CSV File 

To log the data points for a snapshot of a measurement as a .csv file, follow these 
steps: 

1. Select the  button.  
2. Select Log> Measurements> Config. The Log Measurement Configure menu 

appears.  

3. Select the  button. The Save Current Measurements dialog box 
appears.  

4. Select the  icon to create a new directory. The Input Directory Name 
dialog box appears. 

5. Enter "Tutorial" as the directory name. View the Input Directory Name dialog 
box.  

6. This ensures that the application does not overwrite files with the same name 
that you may want to save in the default folder. 

7. Select the . View the Save Current Measurements dialog box.  

8. Select the  again. 
9. The application writes information to one file for each measurement on the 

oscilloscope. If a file with the same name exists, the application appends 
information to it.  

10. Launch the Windows Explorer. 
11. Navigate to the TCO1R1R2.csv file. View the path to the TCO1R1R2.csv file.  
12. Copy the file, and move it to a PC where you can open it with a spreadsheet 

program. View the TCO1R1R2.csv file in a spreadsheet program.  

  

Figure 79: Log Measurement /configure menu for a 
Clock-to-Output measurement 
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Figure 80: Input Directory Name dialog box 

   

Figure 81: Save Current Measurements dialog box 
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Figure 82: Path to the TC01R1R2.csv log file 

  

Figure 83: Viewing a data log file in a spreadsheet 
program 

Logging Worst Case Waveforms to .WFM Files 

To log the worst case waveforms as .wfm files, follow these steps: 
1. Select Log> Worst Case Waveforms> Config. The Log Worst Case 

Waveforms Configure menu appears.  

2. Select the  button. The Log Worst Case Waveforms browser 
appears. 
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3. Create a new folder and name it Tutorial. To do so, refer to steps 3 and 4 in 
the previous procedure.  
This ensures that the application does not overwrite files with the same name 
that you may want to save in the default folder. View the Log Worst Case 
waveforms dialog box. 

4. Select the  button.  
5. Select any menu from the Results drop down list to access the Control Panel.  

6. Select the  button.  
The application writes information to a maximum value file and to a minimum 
value file for each measurement and input channel. There are four files written 
for the two channel measurement Clock-to-Output. If a file with the same 
name exists, the application appends information to it. 

7. Launch the Windows Explorer. 
8. Navigate to the worst case waveform files for the Clock-to-Output 

measurement. View the path to the .wfm files for the Clock-to-Output 
measurement.  

  

Figure 84: Log Worst Case Waveforms configuration for 
a Clock-to-Output measurement 
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Figure 85: Log Worst Case Waveforms dialog 

   

Figure 86: Path to the worse case .wfm log files 

Lessons Learned 

You should now be familiar with the basic functions of the TDSJIT3 v2 
application and menus, and understand how to do the following tasks: 
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• Set up the application  
• Take single waveform and two waveform measurements 
• View summaries of the measurement setup 
• View the results as statistics and as plots 
• Log statistics to a .csv file  
• View a .csv file in a spreadsheet program 
• Log data points for a snapshot of a measurement to a .csv file 
• Log worst case waveforms to .wfm files 
• Exit and return to the application by saving and recalling setup files 

Note: You can use the Jitter Wizard to quickly setup and achieve results for 
many measurements that do not require more advanced configuration. Refer to 
the following groups of topics for information on the common and advanced 
features: 
• Operating Basics  
• Application Examples  
• GPIB Protocol  
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Application Examples 

These simplified application examples highlight the TDSJIT3 v2 Advanced 
measurements and give you ideas on how to use the application to solve your own 
test problems. The application includes the following waveform files you can recall 
to a reference memory to try out each example:  
• EXAMPLE-R1.wfm (data signal)  
• EXAMPLE-R2.wfm (data signal)  

Note: You must have the TDSJIT3 v2 application installed and enabled on the 
oscilloscope. For information, see Installation. 

Requirements:  
• TDS/CSA7000 series oscilloscope or TDS6000 series oscilloscope 
• TDSJIT3 v2 Jitter Analysis software 

Note: If your oscilloscope setup includes a second monitor, you can select and drag 
the title bar of the online help window to position it in the second monitor. This 
allows you to display these application examples in the second monitor, and still 
view the waveform (or a plot) and the TDSJIT3 v2 measurement results on the 
oscilloscope. 

Set the oscilloscope controls to default settings.  

Recall Default Settings 
If you want to work through these examples on the waveforms included with the 
application, the results will match those shown in these topics. To ensure that your 
results match the results shown in these exercises, you need to recall the default 
settings to the oscilloscope. To do so, follow these steps: 
1. Push the DEFAULT SETUP front-panel button to set the oscilloscope to the 

default factory settings. 
2. Push the individual CH1, CH2, CH3, and CH4 buttons as needed to remove 

active waveforms from the display. 

Note: The TDSJIT3 v2 application recalls its default settings when you start the 
application. 

Recall a Waveform and Start the Application 
Recall the appropriate file (such as the EXAMPLE-R1.wfm file) to the Ref1 
memory location on the oscilloscope. For information on how to do so, refer to the 
Recalling a Waveform File topic in the Tutorial. 

Then, start the application.  

Note: This is the basic starting point for most jitter measurements. The main 
difference is that measurements are usually taken from "live" channel waveforms. 
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Application Example 1: Spectral Analysis 
This example shows a simple method to find jitter sources using spectral analysis, a 
powerful tool for diagnosing problems and allowing a method to quantify design 
changes made to improve system performance. 

The first example demonstrates the following tasks:  
• How to measure the Data Period and Time Interval Error of a data signal  
• How to determine the pattern repeat interval 
• How to measure Rj/Dj 
• How to determine jitter components using spectral analysis 

Set Up and Take Measurements for Example 1 

To set up this example and take measurements, follow these steps: 
1. To set the TDSJIT3 v2 application to default values, select File> Default Setup. 

This is not necessary if you just started the application. 
If you just started the application, close the Jitter Wizard menu to reveal the 
Measurement Select menu.  
Since this is a data signal, you need to take Data measurements. This distinction 
allows the software to improve the handling of different data encoding formats, 
such as 8B10B.  

2. If necessary, select Measurements> Select> Data. The Measurement Select 
menu appears with the Data measurement buttons in the Add Measurement area.  

3. Select Ref1 from the pop-up list of Select Source Data options.  
4. Select the Period button in the Add Measurement area, and then the TIE button.  
5. Select the Go To Results button. The All Statistics results menu appears. 
6. Select the Single button to start sequencing and take measurements. View the 

results.  
With "live" channel waveforms, you can use the Run/Stop button to reacquire 
data and repeat the measurement process for each new acquisition. 

At this point, you can see that the Data Period is 399.99 ps, or a 2.5 Gbps waveform. 

Now you can use a repeating pattern with a known pattern length to quickly 
determine accurate Rj/Dj values. To do so, refer to the Approximate Pattern Length 
Measured with Cursors topic. 



 Application Examples 

TDSJIT3 v2 Jitter Analysis Online Help 

 

107

  

Figure 87: Data Period results for example 1 

Approximate Pattern Length Measured with Cursors 

A repeating pattern with a known pattern length allows you to use spectral analysis 
to identify jitter components. 

Since the data period is close to 400 ps, you can calculate the pattern length if you 
can determine the time between repeats. To determine the time between repeats, 
follow these steps: 
1. Push the front panel Horizontal Zoom button. 
2. Turn the Factor multipurpose knob to adjust the horizontal zoom factor until a 

repeating pattern appears. 
A zoom factor of 20 shows that there is a pattern, and at 50 the pattern breaks 
become clear. At a zoom factor of 100, the pattern duration can easily be 
measured with cursors.  

3. Push the front panel Cursors button and adjust the cursors to the beginning and 
end of one of the repeats. 

4. Push the front panel Fine button and adjust the cursors so they overlap the 
midpoint crossings of the falling edges of the long sequence of ones followed by 
a long sequence of zeros. View the Pattern Length measured with cursors.  

5. The cursors show a ∆t of 50.8 ns. With a data period of 400 ps, you can use the 
following equation to calculate the number of bits in each repeat: 

Nbits = ∆t / UI 
With the values used here, 50.8E-9 / 400E-12 = 127, the repeating pattern is 127 
bits. In this case, the waveform is a capture of a PRBS 27-1 LVPECL signal 
operating at 2.5 Gbps. 

Now that you know the length of the repeating pattern, you can measure the Rj/Dj 
and Tj @ BER of the waveform. To do so, refer to the Measuring Rj/Dj and Tj @ 
BER topic. 
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Figure 88: Pattern Length for example 1 

Measuring Rj/Dj and Tj @ BER 

You can measure the Rj/Dj of a signal with any TIE measurement. This includes 
clock and data measurements, and PLL measurements. The advantage of a PLL 
based measurement is that it excludes lower frequency jitter components from the 
results. 

To measure the Rj/Dj of the waveform, follow these steps: 
1. Select Measurements> Configure Meas> General.  
2. Select the Data TIE1 measurement. 
3. Set up the TIE: Rj/Dj options as follows: 

a) Data Pattern Type is Repeating. 
b) Pattern Length is 127. 
c) Separation is On. 

4. Select the Go To Results button, and then the RjDj tab. 
The Rj/Dj results show the breakdown of the random and deterministic 
components within the composite TIE measurement.  
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Of the 25.63 ps Std Deviation and the 131.17 ps Peak-to-Peak values, 6.85 ps is 
random jitter, 20.35 ps is periodic jitter, and 89.92 ps is data dependent jitter. If you 
continued to measure the composite TIE on a live signal until the measured 
population was 1E12, the Peak-to-Peak result would approximate the Tj @ BER 
value. 

Now that you determined the amount of jitter, you need to find the source of jitter. 
One way to find the source is with spectral analysis. To do so, refer to the Using 
Spectral Analysis to Find Jitter Sources topic. 

 

Figure 89: Rj/Dj results for example 1 

Using Spectral Analysis to Find Jitter Sources 

The designer needs to know more than just the amounts of jitter. The designer also 
needs to locate, quantify, and then determine the cause of jitter to improve system 
performance.  

One way to find the source is with spectral analysis. Not with spectral analysis of the 
original signal, but with spectral analysis of the composite jitter in the original 
signal. The TDSJIT3 application does this by treating the measurement array as a 
new sampled data set. 



Application Examples 

 

 TDSJIT3 v2 Jitter Analysis Online Help 

 

110 

To view the spectral components of the jitter on this waveform, you need to create a 
spectral plot. To do so, follow these steps: 
1. Select Plot> Create.  
2. Select the Data TIE1 measurement, and then the Add Plot Spectrum button. A 

plot displays. 
3. You may need to select the Select View button to reposition the plot. 
4. Carefully inspect the plot. 

You will notice several spurs occur at regular intervals. This is normal for data 
waveforms. The spurs are caused by data dependent sources. Normally, the 
largest offender is inter-symbol interference (ISI). This is primarily due to the 
frequency dependent losses in transmission lines, but also can be affected by 
other factors, such as signal reflections. 

5. Select the Zoom controls, and then use the Zoom tools to zoom in to the lower 
third of the Spectrum plot. You can see that there are a few spurs that are not 
regularly spaced. View the spurs.  

6. Select the Cursor controls, and then use the Horizontal cursors tool to examine 
the spurs at 125 MHz and 250 MHz. 
These two spurs alone contribute 1.8 ps and 1.5 ps jitter. This noise is from a 
nearby oscillator that is on the circuit board generating the test signal. The 
oscillator is injecting significant 125 MHz energy (and harmonics) into the  
2.5 Gbps data signal. If faced with marginal compliance, this knowledge would 
allow a designer to quantify improvements made to reduce noise from this  
125 MHz source. 

  

Figure 90: Spurs for example 1 
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Application Example 2: Trend Analysis 
This example shows a simple way to find modulation extremes, a useful tool for 
diagnosing problems and evaluating oscillator performance under real world 
conditions. 

The second example demonstrates the following tasks:  
• How to measure the Data Period of a data signal  
• How to determine the spread spectrum modulation amplitude 

Set Up and Take Measurements for Example 2 

To set up this example and take measurements, follow these steps: 
1. Recall the EXAMPLE-R2.wfm file to the Ref1 memory location on the 

oscilloscope. For information on how to do so, refer to the Recalling a Waveform 
File topic in the Tutorial. 

2. To set the TDSJIT3 application to default values, select File> Default Setup. This 
is not necessary if you just started the application.  
If you just started the application, close the Jitter Wizard menu to completely 
reveal the Measurement Select menu. 
Since this is a data signal, you need to take Data measurements. This distinction 
allows the software to improve the handling of different data encoding formats, 
such as 8B10B.  

3. If necessary, select Measurements> Select> Data. The Measurement Select menu 
appears with the Data measurement buttons in the Add Measurement area.  

4. Select Ref1 from the pop-up list of Select Source Data options.  
5. Select the Period button in the Add Measurement area.  
6. Select the Configure Meas button, and then the Filters tab. 
7. Set up the Filters options as follows: 
8. Low Pass (F2) Filter Spec is set to 2nd Order. 
9. Freq (2) is set to 1 MHz. 

10. Select the Go To Results button. The All Statistics results menu appears. 
11. Select the Single button to start sequencing and take measurements. View the 

results.  
With "live" channel waveforms, you can use the Run/Stop button to continuously 
reacquire data and repeat the measurement process for each new acquisition. 

You can directly compare the minimum and maximum data period values to your 
specification limits. In many situations, you may want to view the sequential effects 
of the modulation, especially when the modulation changes direction from 
downspread to upspread. One way to view the effects is to create a Time Trend plot 
of the period measurements. To do so, refer to the Using Trend Analysis to Find 
Jitter Amplitude and Anomalies topic. 
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Figure 91: Data Period results for example 2 

Using Trend Analysis to Find Jitter Amplitude and Anomalies 

To view the sequential effects of modulation (especially when it changes direction 
from downspread to upspread), you need to create a Time Trend plot. To do so, 
follow these steps: 
1. Select Plot> Create.  
2. Select the Data Period1 measurement, and then the Add Plot Time Trend button. 

A plot displays that clearly shows the modulation profile. In this example, the 
modulation is from a triangular SSC source. View the plot.  
You can use the plot analysis tools to further examine the modulation profile and 
find worst-case events. 

3. Select the Cursor controls, and then the Vertical cursors tool. 
There are several ways to move the cursors: touch and drag (touch screen), click 
and drag (mouse), and general purpose knobs. You can also use the Min-Max 
cursor button to place the cursors on the minimum and maximum extremes. 
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4. Select the Min-Max button. 
The application moves the cursors to the minimum and maximum periods in the 
acquisition. The cursor readout shows that the minimum period is 333.3 ps and 
the maximum period is 335.0 ps. This is the ideal 0.5% downspread for a 3 Gbps 
signal. 
You can use the cursor synchronize and waveform zoom tools to conduct further 
analysis.  

5. Use the plot position tool to reposition the Time Trend plot in the lower half of 
the display. 

6. Select the Sync cursor tool. This places the oscilloscope primary cursors at the 
exact points where the two SSC profile extremes occur.  

7. Select the Zoom controls, and then use the Zoom tools to examine more details of 
the waveform at the time of the minimum and maximum events. 

  

Figure 92: Time Trend plot for example 2 
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Algorithms 

The TDSJIT3 v2 application can take timing measurements from one or two 
waveforms. The number of waveforms used by the application depends on the 
type of measurement being taken. 

Oscilloscope Setup Guidelines 
For all measurements, use the following guidelines to set up the oscilloscope: 
• The signal is any channel, reference, or math waveform. 
• The vertical scale for the waveform must be set so that the waveform does not 

exceed the vertical range of the oscilloscope. 
• The sample rate must be set high enough to capture sufficient waveform detail 

and avoid aliasing. 
• Longer record lengths increase measurement accuracy but the oscilloscope 

takes longer to measure each waveform.  

Test Methodology 
The application performs the measurement according to the following steps: 
1. Imports the current waveform. 
2. Checks that the reference voltage level plus or minus half the hysteresis are 

within the 2.5% to 97.5% range of the peak-to-peak waveform values. 
3. Checks that there are a minimum number of edges in the waveform to 

calculate the measurement as follows: 

• Single edge: Rise Time, Fall Time 

• One edge pair: Pulse Width, High Time, Low Time 

• Two cycle-start edges: Period, Frequency, Duty Cycle 

• Three cycle-start edges: Cycle-to-Cycle, TIE, PLL TIE 

• Clock TIE and PLL TIE measurements require 500 edges for RjDj analysis 
(TDSJIT3 v2 Advanced only) 

• Data TIE , PLL TIE, and Clock-Data-TIE measurements require 100 
repeated patterns or 10 K edges of an arbitrary pattern (TDSJIT3 v2 
Advanced only) 

• 2N + 1 cycle-start edges: N-Cycle 

• Two edges on each of two waveforms: Skew, Crossover Voltage (TDSJIT3 
v2 Advanced only) 

4. Performs the measurement. 
5. Displays the results as statistics. You can also log the results or data points to 

a .csv file. 
6. Displays the results as a plot if set up. 
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Timing Measurements 
All timing measurements are based on the time locations of edges within each 
acquisition. Edge conditions are defined in the setup menu of each timing 
measurement. Tn represents the acquisition edge times where n is an index 
between 1 and the number of edges in the acquisition. 

The "i" and "j" represent dissimilar acquisition indices. Dissimilar acquisition 
indices occur when the correlation between clock edges and a data transitions are 
not one-to-one. 

Rj/Dj Measurement (TDSJIT3 v2 Advanced Only) 

The Rj/Dj measurement calculates the deterministic and random components of a 
jitter. The jitter is obtained from the TIE measurements. Rj is the random jitter. It 
is assumed to be Gaussian and has a flat spectrum. The Rj measurement 
calculates the standard deviation of the random jitter. Dj is the deterministic 
jitter. It is predictable and can be generated consistently given known 
circumstances. Dj has a spectrum of impulses when the data signal has a 
repeating pattern. The Dj measurement calculates the peak-to-peak value of the 
deterministic jitter. Tj is the total jitter, which is composed of Dj and Rj. The Tj 
measurement calculates the peak-to-peak value of the total jitter at the specified 
BER.  

Two approaches are supported. The first method is a spectrum analysis based 
approach (default) when the data pattern is repetitive. A clock waveform is 
always repetitive. Other repetitive testing data patterns are used, such as the 
K28.5 data pattern.  

The second R/Dj separation method is an arbitrary pattern analysis based 
approach when the data pattern is not necessarily repetitive. For a long PRBS 
data pattern, the data is virtually non-repetitive within a single acquisition. 

Spectrum Analysis Based Rj/Dj Separation 

Deterministic Jitter (Dj) has a spectrum of equally-spaced impulses when the 
data signal has a repeating pattern. To obtain measurements of Dj and Rj, the 
application distinguishes the deterministic impulses from the noise floor in the 
spectrum of total jitter.  

The application calculates Rj measurement using the following equation: 
 Rj=Standard deviation(noise floor of jitter spectrum) 
The application calculates the Dj measurement using the following equation: 

 )()( TimeTime DjMinDjMaxDj −=  

Where:  Dj is the deterministic jitter. 

 
TimeDj  is the time domain record of the Dj component of jitter obtained 

by performing an inverse FFT of the Dj components of the TIE spectrum. 

• Dj is composed of ISI, DCD and Pj: ISI is the Inter-Symbol Interference. It is 
also called DDj (Data Dependent Jitter). The ISI measurement calculates the 
peak-to-peak value of the ISI. 
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• DCD is Duty Cycle Distortion. It is the difference in the mean pulse width of 
positive pulse width compared to the mean pulse width of negative pulse 
width. The DCD measurement calculates the peak-to-peak value of the DCD.  

• Pj is periodic jitter. The Pj measurement calculates the peak-to-peak value of 
the Pj. 

For a data signal with a repetitive data pattern, Dj has a spectrum of impulses. All 
impulses due to DDJ ISI+DCD components must appear at multiples of fo/N 
where fo is the data bit rate and N is the data pattern length. Any remaining 
impulses are due to Pj. 

The application distinguishes the impulses that appear due to ISI+DCD and 
impulses due to Pj.  

The application calculates Pj measurement using the following equation: 

 )()( TimeTime PjMinPjMaxPj −=  

Where:  Pj is the deterministic jitter. 

 
TimePj is the time domain record of Pj obtained by performing an inverse 

FFT on Pj components of the TIE spectrum. 

The application calculates the time domain histogram of ISI+DCD for the rising 
edges and for the falling edges respectively.  

The application calculates ISI measurement using the following equation: 

 ( ) 2)()()()( FallFallRiseRise HMinHMaxHMinHMaxISI −+−=  

 
)()( FallRise HMeanHMeanDCD −=

 

Where:  ISI is the inter-symbol interference. 

 DCD is the duty cycle distortion. 

 
RiseH is the time domain histogram of ISI+DCD for the rising edges. 

 
FallH is the time domain histogram of ISI+DCD for the falling edges. 

Arbitrary Pattern Analysis Based Rj/Dj Separation 

When the data pattern is non-repeating, Pj still has a spectrum of impulses, while 
ISI+DCD no longer has a spectrum of impulses. Therefore, Dj no longer has a 
spectrum of impulses.  

The ISI+DCD value is obtained through the arbitrary data pattern analysis 
method which is based on the assumption that any given bit is affected by a finite 
number of preceding bits. By averaging all events where the current bit is 
preceded by a particular bit sequence, for example the current bit is preceded by 
the bit sequence 1001101, the ISI+DCD with such a pattern is obtained since PJ 
and RJ are not correlated to a particular data sequence and thus are averaged out.  

If each bit is assumed to be affected by N preceding bits, there are a total of 2N 
possible data sequences. The sequence length N is a configurable parameter. To 
get statistical sound average values, a population limit is the other configurable 
parameter which prevents using an average value without enough population. 
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Only ISI+DCD values obtained from data sequences with a population above the 
limit are used to calculate ISI+DCD values. 

After each edge is associated with an ISI+DCD value, with known total jitter, the 
PJ+RJ value for each bit is then obtained by subtracting ISI+DCD from TJ. 

Separation of ISI and DCD from ISI+DCD is the same as that in the spectrum 
based Rj/Dj separation method. 

Pj and Rj is then separated from Pj+Rj and uses the spectrum analysis method. PJ 
has a spectrum of impulses, Rj has a flat spectrum. All the edges whose 
ISI+DCD can not be determined because of their associated data sequences have 
low populations and are treated as if there are no edges when performing Pj and 
Rj separation. 

The histogram of Dj is a convolution of the histogram of ISI+DCD and the 
histogram of Pj. 

All other aspects of the arbitrary pattern analysis based Rj/Dj separation are the 
same as those of the spectrum analysis based Rj/Dj separation.  

BER and Tj Estimation (TDSJIT3 v2 Advanced Only) 

The BER Estimation calculates the bit error rate curve and the eye opening for a 
given bit error rate. After the Rj/Dj separation, the recovered histogram of the 
total jitter can be computed. The recovered Tj histogram, when properly 
normalized, can be interpreted as the probability density function (PDF) of the 
Tj. 

Integration of the PDF yields the CDF, which can then be used to create the bit 
error rate curve (bathtub curve). Based on the bathtub curve, the eye opening can 
be estimated for a given bit error rate.  

The application calculates the recovered total jitter histogram using the following 
equation: 

 
RjDjTj HHH ⊗=  

Where: 
TjH is the recovered histogram of total jitter. 

 
DjH is the histogram of Dj and is computed from the time record of Dj 

after the RjDj separation. 

 
RjH is the histogram of Rj and is synthesized based on its Gaussian 

model after the RjDj separation. 

The application calculates the eye opening at the specified BER using the 
following equation: 
 Eye opening = 1-Tj/UI when Tj is < UI 
 Eye opening = 0 when Tj is = UI 
Where:  UI is the unit interval in seconds. 

Effective Rj and Tj Estimation (TDSJIT3 v2 Advanced only) 

Effective Rj and Dj is a way to define Rj and Dj to avoid instrument- or vendor-
specific jitter separation models. This estimation method fits the Bathtub curve to 
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a theoretical model of Rj and Dj where Rj is assumed to have a Gaussian 
distribution, Dj is assumed to have a distribution of two Dirac impulses with the 
same height. Two point curve fitting at BER levels of 10-5 and 10-9 in Bathtub 
curve is implemented to get effective Rj and Dj. The Bathtub curve is obtained 
from the spectrum analysis based or the arbitrary pattern analysis based Rj/Dj 
separation methods.  

Usually, the value of the effective Rj is greater than the value of Rj obtained from 
the spectrum analysis based or the arbitrary pattern analysis based Rj/Dj 
separation. The value of the effective Dj is less than that of its corresponding one. 

After the effective Rj and Dj are obtained, the histogram of effective Tj can be 
calculated by a combination of the histogram of the effective Rj and the 
histogram of the effective Dj. Then the effective Tj and the effective eye opening 
can be computed in the same way described in the previous topic. 

The detailed description is available from the T11 Web site. 

Single Waveform Measurements 
The application defines conditions for a single waveform to take the following 
measurements: 

Table 42: Single waveform measurements 

Clock Data General 
Period N-Cycle Period Rise Time 
Frequency Positive Cy-Cy Duty Frequency Fall Time 
TIE Negative Cy-Cy Duty TIE Positive Width 
PLL TIE* Positive Duty Cycle PLL TIE* Negative Width 
Cycle-Cycle Negative Duty Cycle  High Time 
  Low Time 
* TDSJIT3 v2 Advanced only. 
  

Clock Period Measurement 

The Clock Period measurement calculates the duration of a cycle as defined by a 
start and a stop edge. Edges are defined by slope, threshold, and hysteresis. 

The application calculates this measurement using the following equation: 

 nn
Clock

n TTP −= +1  

Where: 
ClockP is the clock period.  

 T  is the VRefMid crossing time in the Cycle Start Edge direction 

Clock Frequency Measurement 

The Clock Frequency measurement calculates the inverse of the clock period for 
each cycle. 

The application calculates this measurement using the following equation: 

 
Clock

n
Clock

n PF /1=  
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Where: 
ClockF is the clock frequency. 

 
ClockP is the clock period measurement.  

Clock TIE Measurement 

The Clock TIE measurement calculates the difference in time between the 
specified clock edge on a sampled clock waveform to the corresponding edge on 
a recovered clock waveform with a constant frequency (zero jitter). 

The application calculates this measurement using the following equation: 

 
Clock
n

Clock
n

Clock
n TTTIE '−=  

Where:  
ClockTIE is the clock time interval error. 

 
ClockT is the VRefMid crossing time for the specified clock edge. 

 
ClockT ′ is the recovered VRefMid crossing time by means of linear 

regression. 

Clock PLL TIE Measurement (TDSJIT3 v2 Advanced Only) 

The Clock PLL TIE measurement calculates the difference in time between the 
specified edges on a sampled clock waveform to the corresponding edge on a 
clock waveform calculated by means of a PLL. Low frequency TIE components 
that are within the loop bandwidth of the PLL are tracked by the PLL and thereby 
removed.  
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The application calculates this measurement using the following equation: 

 
Clock
n

Clock
n

Clock
n TTTIE '−=  

Where: 
ClockTIE is the clock time interval error. 

 
ClockT is the VRefMid crossing time for the specified clock edge. 

 
ClockT ′ is the recovered VRefMid crossing time by means of a PLL.Data 

Period Measurement 

The Data Period measurement calculates the duration of a cycle as defined by a 
start and a stop edge. Edges are defined by threshold, and hysteresis. 

The application calculates this measurement using the following equation: 

 )/()( 11 −− −−= nn
Data

n
Data

n
Data

n CCTTP  

Where:  
DataP is the data period. 

 
DataT is the VRefMid crossing time in either direction. 

 nC is the calculated clock cycle location of
Data

nT . 

Data Frequency Measurement 

The Data Frequency measurement calculates the inverse of the data period for 
each cycle. 

The application calculates this measurement using the following equation: 

 
Data

n
Data

n PF /1=  

Where:  
DataF is the data frequency. 

 
DataP is the data period measurement.  

Data TIE Measurement 

The Data TIE measurement calculates the difference in time between an edge on 
a sampled data waveform to the corresponding edge on a recovered data 
waveform with a constant frequency (zero jitter). 

The application calculates this measurement using the following equation: 

 
Data
n

Data
n

Data
n TTTIE '−=  

Where: 
DataTIE is the data time interval error. 

 
DataT is the VRefMid crossing time in either direction. 

 
DataT ′ is the recovered VRefMid crossing time by means of linear 

regression. 

Data PLL TIE Measurement (TDSJIT3 v2 Advanced Only) 

The Data PLL TIE measurement calculates the difference in time between the 
designated edge on a sampled data waveform to the designated edge on a data 
waveform calculated by means of a PLL. Low frequency TIE components that 
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are within the loop bandwidth of the PLL are tracked by the PLL and thereby 
removed. The application calculates this measurement using the following 
equation: 

 
Data
n

Data
n

Data
n TTTIE '−=  

Where: 
DataTIE is the data time interval error. 

 
DataT is the VRefMid crossing time in either direction. 

 
DataT ′ is the recovered VRefMid crossing time by means of a PLL. 

Cycle-to-Cycle Measurement 

The Clock Cycle-to-Cycle measurement calculates the difference in period 
measurements from one cycle to the next. 

The application calculates this measurement using the following equation: 

 
Clock

n
Clock

nn PPP −=∆ +1  

Where:  P∆ is the difference between adjacent periods. 

 
ClockP is the clock period measurement.  

N-Cycle Measurement 

The N-Cycle measurement calculates the difference in clock period 
measurements from cycles that are a defined number of cycles apart.  

The application calculates this measurement using the following equation: 

 )()( 2
++

+
+
+

+
+ −−−=∆ nNnNnNnn TTTTNP  

Where:  NP∆ is the difference between adjacent N–cycle periods. 

 
+T is the VRefMid crossing time in the Common Cycle Start Edge 

direction. 

Positive and Negative Cycle-to-Cycle Duty Measurements 

The Positive Cycle-to-Cycle Duty and Negative Cycle-to-Cycle Duty 
measurements calculate the difference in positive (or negative) pulse widths from 
one cycle to the next. 
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The application calculates these measurements using the following equations: 

 
−−−

+++

−=∆

−=∆

nnn

nnn

WWW

WWW

 

Where:  
+∆W is the difference between positive pulse widths of adjacent clock 

cycles. 

 
−∆W is the difference between negative pulse widths of adjacent clock 

cycles. 

 
+W is the positive pulse width measurement.  

 
−W is the negative pulse width measurement.  

Positive and Negative Duty Cycle Measurements 

The Positive Duty Cycle and Negative Duty Cycle measurements calculate the 
ratio of the positive (or negative) portion of the cycle relative to the period.  

The application calculates these measurements using the following equations: 

 
Clock

nnn

Clock
nnn

PWD

PWD

/

/
−−

++

=

=

 

Where:  
+D is the positive duty cycle. 

 
−D is the negative duty cycle. 

 
+W is the positive pulse width. 

 
−W is the negative pulse width. 

 
ClockP is the period. 

Rise Time Measurement 

The Rise Time measurement is the time difference between when the VRefHi 
reference level is crossed and the VRefLo reference level is crossed on the rising 
edge of the waveform. The Rise Time algorithm uses the VRef values as the 
reference voltage level. Each edge is defined by the slope, voltage reference level 
(threshold), and hysteresis.  

The application calculates this measurement using the following equation: 

 
++ −= Lo

n
Hi

n
Rise

n TTT  

Where:  
RiseT is the rise time. 

 
+HiT is the VRefHi crossing on the rising edge. 

 
+LoT is the VRefLo crossing on the rising edge. 

Fall Time Measurement 

The Fall Time measurement is the time difference between when the VRefLo 
reference level is crossed and the VRefHi reference level is crossed on the falling 
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edge of the waveform. The Fall Time algorithm uses the VRef values as the 
reference voltage level. Each edge is defined by the slope, voltage reference level 
(threshold), and hysteresis. The application calculates this measurement using the 
following equation: 

 
−− −= Hi

n
Lo

n
Fall

n TTT  

Where:  
FallT is the fall time. 

 
−LoT is the VRefLo crossing on the falling edge. 

 
−HiT is the VRefHi crossing on the falling edge. 

Positive and Negative Width Measurements 

The Positive Width and the Negative Width measurements are the difference in 
time (positive or negative) between the leading edge and trailing edge of a pulse. 
The trailing edge is the opposite polarity (direction) of the leading edge. 

The application calculates these measurements using the following equations: 

 
−+−

+−+

−=

−=

nnn

nnn

TTW

TTW

 

Where:  
+W is the positive pulse width. 

 
−W is the negative pulse width. 

 
−T is the VRefMid crossing on the falling edge. 

 
+T is the VRefMid crossing on the rising edge. 

High Time Measurement 

The High Time Measurement is the amount of time that a waveform cycle is 
above the VRefHi voltage reference level. 

The application calculates the measurement using the following equation: 

 
+− −= Hi

n
Hi

n
High

n TTT  

Where:  
HighT is the high time. 

 
−HiT is the VRefHi crossing on the falling edge. 

 
+HiT is the VRefHi crossing on the rising edge. 

Low Time Measurement 

The Low Time measurement is the amount of time that a waveform cycle is 
below the VRefLo voltage reference level. 

The application calculates this measurement using the following equation: 

 
−+ −= Lo

n
Lo

n
Low

n TTT  

Where: 
LowT is the low time. 

 
+LoT is the VRefLo crossing on the rising edge. 
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−LoT is the VRefLo crossing on the falling edge. 

Dual Waveform Measurements 
The application defines conditions for a two waveforms. These algorithms use 
the VRef values as the reference voltage level. Each edge is defined by the slope, 
voltage reference level (threshold), and hysteresis. 

Table 43: Dual waveform measurements 

Setup 
Hold 
Clk-Out 
Skew 
Crossover Voltage (TDSJIT3 v2 Advanced only)  
  

Setup Time Measurement 

The Setup Time measurement is the elapsed time between the designated edge of 
a data waveform and when the clock waveform crosses its own voltage reference 
level. The closest data edge to the clock edge that falls within the range limits is 
used. 

The application calculates this measurement using the following equation: 

 
nd

n
Main

i
Setup

n TTT 2−=  

Where:  
SetupT is the setup time. 

 
MainT is the Main input (clock) VRefMidMain crossing time in the 

specified direction. 

 
ndT 2

is the 2nd input (data) VRefMid2nd crossing time in the specified 
direction. 

Hold Time Measurement 

The Hold Time measurement is the elapsed time between when the clock 
waveform crosses its own voltage reference level and the designated edge of a 
data waveform. The closest data edge to the clock edge that falls within the range 
limits is used. 

The application calculates this measurement using the following equation: 

 
Main

i
nd

n
Hold

n TTT −= 2

 

Where: 
HoldT is the hold time. 

 
MainT is the Main input (clock) VRefMidMain crossing time in the 

specified direction. 

 
ndT 2

is the 2nd input (data) VRefMid2nd crossing time in the specified 
direction. 
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Clock-to-Output Meas.urement 

The Clock-to-Output Time measurement is the elapsed time between when the 
clock waveform crosses its own voltage reference level and the designated edge 
of a data waveform. The closest data edge to the clock edge that falls within the 
range limits is used. 

The application calculates this measurement using the following equation: 

 
Main

i
nd

n
ClkOut

n TTT −= 2

 

Where: 
ClkOutT is the clock–to–output time.  

 
MainT is the Main input (clock) VRefMidMain crossing time in the 

specified direction.  

 
ndT 2

is the 2nd input (data) VRefMid2nd crossing time in the specified 
direction.  

Clock-Data-TIE Measurement 

The Clock-Data-TIE measurement calculates the difference in time between an 
edge on a sampled data waveform to the corresponding edge on a sampled clock 
waveform. 

The application calculates this measurement using the following equation: 
TIEDataClock

nT −− = nd
nT 2 – main

iT  

Where: TIEDataClock
nT −−  is the Clock-Data-TIE measurement. 

nd
nT 2  is the 2nd input (data) VRefMid2nd crossing time. 

main
iT  is the Main input (clock) VRefMidMain crossing time in the 

specified direction delayed by specified direction delayed by specified 
clock delay time. 

 

Skew Measurement 

The Skew measurement calculates the difference in time between the designated 
edge on a principal waveform to the designated edge on another waveform. The 
closest data edge to the clock edge that falls within the range limits is used. 

The application calculates this measurement using the following equation: 

 
nd

n
Main

n
Skew

n TTT 2−=  

Where:  
SkewT is the timing skew. 

 
MainT is the Main input VRefMidMain crossing time in the specified 

direction.  

 
ndT 2

is the 2nd input VRefMid2nd crossing time in the specified direction.  
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Crossover Voltage Measurement (TDSJIT3 v2 Advanced Only) 

The Crossover Voltage measurement calculates the voltage level at the crossover 
voltage of a differential signal pair. If there is timing jitter on one of the pair of 
signal lines relative to the other, the crossover point will be modulated by the 
jitter. Crossover times are determined from the math waveform (main-cross) for a 
reference level of 0 V.  

The application calculates this measurement using the following equation: 

 )( Crossover
n

Main
n

Crossover
n TVV =  

Where:  
CrossoverV is the crossing voltage. 

 
MainV is the voltage of the Main input. 

 
CrossoverT is the crossover time when the two waveforms are equal in 

voltage.  

Statistics 
The application calculates statistics for all selected measurements. The 
application displays the following statistics in the Results menus: 
• Maximum value  
• Minimum value  
• Mean value  
• Standard deviation value  
• Peak-Peak value  
• Population  

Maximum Value 

The application calculates this statistic using the following equation: 
 Max(X)=Highest Value of X 

Minimum Value 

The application calculates this statistic using the following equation: 
 Min(X)=Lowest Value of X 

Mean Value 

The application calculates this statistic using the following equation: 

 
∑
=

==
N

n
nX

N
XXMean

1

1)(
 

Standard Deviation Value 

It may seem odd that the equation for the estimate of the Standard Deviation 
contains a 1/(N-1) scaling factor. If you knew the true mean of X and used in 
place of the estimated mean  , then you would, in fact, scale by1/N. But,  is 
an estimate and is likely to be in error (or bias), causing the estimate of the 
Standard Deviation to be too small to be scaled by 1/N. This is the reason for the 
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scaling shown in the equation. (Refer to Chapter 9.2 in A. Papoulis, Probability, 
Random Variables, and Stochastic Processes, McGraw Hill, 1991.) 

The application calculates this statistic using the following equation: 

∑
=

−
−

==
N

n
X XX

N
XStdDev

1

2)(
)1(

1)( σ
 

 

Maximum Positive and Maximum Negative Difference Values 

The application calculates the Max Positive Difference Value using the following 
equation: 

 cccc ofXitiveValueHighestPosXMax =+ )(  

Where: 1−−= nnCC XXX  

The application calculates Max Negative Difference Value using the following 
equation: 

 cccc fXtiveValueoLowestNegaXMax =− )(  

Where: 1−−= nnCC XXX  

The Cycle-Cycle Value below is not displayed, but is used in calculations for 
Max Positive and Max Negative calculations. 

 1−−= nnCC XXX  
Peak-to-Peak Value 

The application calculates this statistic using the following equation: 

 )()()( xMinxMaxxPkPk −=  
Population Value 

Population is the total number of data points applied to the displayed statistics. 

 NXPopulation =)(  
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Parameters 

These topics describe the TDSJIT3 v2 application parameters and include the 
menu default settings. You should refer to the user manual for your oscilloscope 
for operating details of other controls, such as front-panel buttons. 

The parameter tables list the selections or range of values available for each 
option, the incremental unit of numeric values, and the default selection or value. 

Refer to the GPIB topics for a complete list of the GPIB Command Syntax. The 
topics include a complete list of the GPIB commands along with the arguments, 
variables, and variable values that correspond to the TDSJIT3 v2 parameters. 

Note: Unit values shown are valid when the FINE button is enabled on the 
oscilloscope.  

File Menus Parameters 
The File drop down list includes the following options: 
• Default Setup 
• Dock 
• Undock 
• Minimize  
• Exit 

Note: If you create a new directory for setup files, the application remembers the 
path and will save files to and recall files from that directory instead of the 
default directory. 

Table 44: File menus parameters 

Option Parameters Default setting 
Recall <Browser> Default directory* 
Save <Browser> Default directory* 
Recent Files Lists up to four most recently saved or 

accessed setup files:  
1. <setup file name>  
2. <setup file name>  
3. <setup file name>  
4. <setup file name>  

Not applicable 

* Refer to the Application Directories and Usage topic for default path names.  
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Control Panel Parameters 
The Control Panel menu includes the following command buttons: 
• Run/Stop 
• Single 
• New Acq 
• Clear 

Measurements Select 
The Measurements Select menu includes the following areas: 
• Select Source 
• Math Defs 
• Add Measurement 

The Add Measurement area groups the measurements into the following 
categories: 
• Clock: Period, Frequency, TIE, PLL TIE*, Cycle-Cycle, N-Cycle, Positive 

Cy-Cy Duty, Negative Cy-Cy Duty, Positive Duty, and Negative Duty  
• Data: Period, Frequency, TIE, PLL TIE* 
• Clk-Data: Setup, Hold, Clk-Out 
• General: Rise Time, Fall Time, Positive Width, Negative Width, High Time, 

Low Time, Skew, and Crossover Voltage*. 

Note: Both PLL TIE, and Crossover Voltage measurements are available only 
with TDSJIT3 Advanced. 

You can set the Source option as any of the following waveforms: Ch1, Ch2, 
Ch3, Ch4, Ref1, Ref2, Ref3, Ref4, Math1, Math2, Math3, or Math4. 

Table 45: Select Source area parameters 

Measurement category Source name Default parameters 
Clock Clock Ch1 
Data Data Ch1 
Clk-Data Clock, Data Ch1, Ch2 
General Main, Skew/Cross Ch1, Ch2 
  

You can select Scope User if you want to use a math waveform based on a user-
defined math operation. To define your own math operation, use the oscilloscope 
math equation editor. 
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Table 46: Math Defs area parameters 

Option Parameters Default 
Math Math1, Math2, Math3, Math4 Math1 
= Ch1-Ch3, Ch2-Ch4, Ref1-Ref2, Ref3-Ref4, 

Scope User 
Scope User 

  

Configure Measurements 
The application shows Configure Measurement menus that apply to the selected 
measurement. The options available in each Configure Measurement menu are 
specific to the selected measurement. 

Note: Data measurements do not include Waveform Edge options. 

Table 47: Waveform Edges parameters 

 

Table 48: Measurement Range Limits parameters 

Option Parameters Default 
Setup, Hold, Clk-Out: 
   Max. Value 

 
500 ms to -500 ms in 10 ps units 

 
10ns 

   Min. Value 500 ms to -500 ms in 10 ps units 0 ns 
Skew: 
   Max. Value 

 
500 ms to -500 ms in 10 ps units 

 
10 ns 

   Min. Value 500 ms to -500 ms in 10 ps units -10 ns 
Crossover Voltage: 
   Max. Value 

 
10 V to -10 V in 10 mV units 

 
500 mV 

   Min. Value 10 V to -10 V in 10 mV units -500 mV 
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Table 49: Clock-Data-TIE Measurement parameters 

 

Table 50: N-Cycle measurement parameters 

Option Parameters Default 
Clock Edge Rise, Fall, Both Rise 
N=  6 
1st Meas. Start @ Edge 1 to 1k in 1 units 1 
Edge Increment 1 or N 1 
  

Clock Recovery Parameters 

Table 51: Clock Recovery: Reference Clock Frequency 
parameters 

Option Parameters Default 
Autocalc Autocalc 1st Acq, Autocalc Every Acq, 

Custom 
Autocalc Every Acq 

Value* 1 Hz to 5 GHz in 1 Hz units 100 Mhz 
* Available when Custom is selected. 
  

Table 52: Clock Recovery: Loop BW  parameters 

Option Parameters Default 
Loop BW: 
   Standard Frequency 
   (in GHz) 

FC133:0.1328, FC266:0.2656, 
FC531:1.0625, FC1063:11.063,: 
FC2125:2.125, IB2500:2.5, 
SerATAG1:1.5, SerATAG2:3, 
SerATAG3:6, USB_FS:0.12, 
USB_HS:0.48, 
1394b_S400b:0.4915, 
1394b_S800b:0.983, 
1394b_S1600b:1.966, 
GB_Ethernet:1.25, 
100BaseT:0.125, OC1:0.0518, 
OC3:0.155, OC12:0.622, 
OC48:2.488 

FC133:0.1328 

   Custom Value 1 Hz to 50 MHz in 1 Hz units 1 MHz 
PLL Order First, Second First 
Damping 0.5 to 1.0 in .01 units 0.707 
* Available when the PLL Order option is set to Second. 
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Advanced Clock Recovery Parameters 

The Advanced Clock Recovery menu includes the following command buttons: 
• OK 
• Cancel 

Table 53: Advanced Clock Recovery parameters 

Option Parameters Default 
Nominal Data Rate On, Off Off 
   Unit Interval* 100 ps to 1 s in 1 ps units 10 ps 
   Bit Rate* 1 Gb/s to 10 Gb/s 10 Gb/s 
Known Data Pattern On, Off Off 
   Pattern File Name <Browser> Default directory** 
* Available when the Nominal Data Rate option is set to On. 
** Refer to the Application Directories and Usage topic for default path names. 
  

Filters Parameters 

Table 54: Filters parameters 

 
Advanced Filter Parameters 

The Advanced Filter menu has an OK command button. 

Note: The application displays F1 if the High Pass filter is set to On. If the High 
Pass filter is set to Off and the Low Pass filter is set to On, then the application 
displays F2. 

Table 55: Advanced Filter parameter 

Option Parameters Default 
Duration 0/F1 to 10/F1 in .1 units 2/F1 
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TIE: RjDj Analysis Parameters (TDSJIT3 v2 Advanced Only)  

Table 56: TIE: RjDj Analysis parameters (TDSJIT3 v2 
Advanced only) 

Option Parameters Default 
Separation On, Off Off 
BER=1E-? 2 to 18 in whole number units 12 
Type* Repeating, Arbitrary Repeating 
Pattern Length* 2 UI to 1M UI in increments of 1 UI 2 
Window Length*** 2 UI to 16 UI in increments of 1 UI 5 
Population*** 5 to 5000 in units of 1 100 
* Available for Data TIE or Data PLL TIE measurements. 
** Available when the Type option is set to Arbitrary. 
  

Configure Sources 
The application includes the following Configure Source menus:  
• Autoset 
• Gate/Quality 
• Ref Levels (Autoset or manual) 
• Stat Pop Limit 

The application can automatically calculate parameters for reference voltage 
levels based on the Ref Level Autoset Setup menu. Display the Ref Level 
Autoset Setup menu parameters.  

The Configure Source Autoset menu includes the following command buttons: 
• All 
• Vertical Scale 
• Horizontal Resolution 

Table 57: Configure Sources Autoset parameters 

Option Parameters Default 
Optimize Horizontal For Edge Resolution, Max Edge 

Count 
Edge Resolution 
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Table 58: Configure Sources Gate/Qualify parameters 

Option Parameters Default 
Gate Off, Zoom, Cursors Off 
Qualify with 
Logic Waveform 

  

   Source Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, 
Ref4, Math1, Math2, Math3, Math4 

Ch4 

   Active Off, High, Low Off 
  

The Configure Source Ref Levels menu includes the following command buttons 
in the Autoset area: 
• Update  
• Setup  

Table 59: Configure Sources Ref Levels parameters 

Option Parameters Default 
Autoset Set, Clear Set 
Source Ch1, Ch2, Ch3, Ch4, Ref1, Ref2, Ref3, 

Ref4, Math1, Math2, Math3, Math4 
Ch2 

Rise, High 10.00 V to -10.00 V in units of 1 mV 1 V 
Rise, Mid 10.00 V to -10.00 V in units of 1 mV 0 V 
Rise, Low 10.00 V to -10.00 V in units of 1 mV -1 V 
Fall, High 10.00 V to -10.00 V in units of 1 mV 1 V 
Fall, Mid 10.00 V to -10.00 V in units of 1 mV 0 V 
Fall, Low 10.00 V to -10.00 V in units of 1 mV -1 V 
Hysteresis 0 V to 10.00 V in units of 10 mV 30 mV 
* Default settings are 90% (High), 50% (Mid), 10% (Low), and 3% (Hysteresis). 
  

Table 60: Configure Stat Pop Limit parameters 

Option Parameters Default 
Population Control On, Off Off 
Size* 1 to 1 M in units of 1 1 k 
* Available when the Population Control option is set to On. 
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The Configure Ref Level Autoset Setup menu includes the following command 
buttons: 
• OK 
• Cancel 

Table 61: Configure Ref Level Autoset Setup Menu 
parameters 

Option Parameters Default 
Base-Top Method Min-Max, Lo-High (Histogram), Auto Auto 
Rise High 0 to 100% in units of 1% 90% 
Rise Mid 0 to 100% in units of 1% 50% 
Rise Low 0 to 100% in units of 1% 10% 
Fall High 0 to 100% in units of 1% 90% 
Fall Mid 0 to 100% in units of 1% 50% 
Fall Low 0 to 100% in units of 1% 10% 
Hysteresis 0 to 50% in units of 1% 3% 
  

Summaries 
You can view various Measurement Summary menus that show the measurement 
settings. For definitions, see About Measurement Summary Menus.  

Results 
The application offers several types of statistics for you to view the measurement 
results. Some statistics are only valid for specific types of measurements. For 
definitions, see About Viewing Statistics.  

Plots 
The application includes the following Plot menus: 
• Create 
• Vert/Horiz Axis 

The Plots Create menu includes the following command button: 
• Refresh 

The Histogram Vert/Horiz Axis menu includes the following command buttons: 
• Autoset (recalculates the Center and Span values based on the histogram 

measurement statistics and then refreshes the plot) 
• Refresh (refreshes the plot, usually after a manual change of the Center or 

Span options) 
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Table 62: Histogram Vert/Horiz Axis menu parameters 

Option Parameters Default 
Vertical Scale Log, Linear Linear 
No. of bins 25, 50, 100, 250, 500 250 
Center   
   Positive Time 1 ps to 1 s in 1 ps units 100 ns 
   Pos/Neg Time -500 ns to 500 ns in 1 ps units 0 s 
   Frequency 1 Hz to 10 GHz in 1 Hz units 5 GHz 
   Duty Cycle 0% to 100% in 5% units 50% 
   Pos/Neg Volts 1 V to 1 V in 1 mV units 0 V 
Span   
   Positive Time 1 ps to 1 s in 1 ps units 4 ns 
   Pos/Neg Time 1 ps to 1 s in 1 ps units 4 ns 
   Frequency 1 Hz to 10 GHz in 1 Hz units 5 GHz 
   Duty Cycle 0% to 100% in 5% units 50% 
   Pos/Neg Volts 0 V to 1 V in 1 mV units 10 mV 
  

Table 63: Time Trend Vert/Horiz Axis menu parameter 

Option Parameters Default 
Mode Vector, Bar Vector 
  

Table 64: Spectrum Vert/Horiz Axis menu parameters 

Option Parameters Default 
Vertical Scale Log, Linear Linear 
Baseline* -20 dB to 15 dB in .5 dB units -12 
Horizontal Scale Log, Linear Linear 
Mode Normal, Average, Peak Hold Normal 
* Available when the Vertical Scale option is set to Log. 
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Table 65: Bathtub Vert/Horiz Axis menu parameters 

Option Parameters Default 
Vertical Scale Linear, Log Log 
Minimum Displayed BER=1E-?* 2 to 18 in units of 1 12 
* Available when the Vertical Scale option is set to Log. 
  

Table 66: Transfer Function Vert/Horiz Axis menu 
parameters 

Option Parameters Default 
Vertical Scale Log, Linear Log 
Horizontal Scale Log, Linear Log 
Mode Average, Normal Average 
  

Table 67: Phase Noise Vert/Horiz Axis menu parameters 

Option Parameters Default 
Vertical Position Baseline -200 to 0 in units of 1 -170 
Integrated Noise   
   Lower Limit 0 Hz to 10 GHz in 1 Hz units 0 Hz 
   Upper Limit 0 Hz to 10 GHz in 1 Hz units 1 MHz 
  

Logs 
The application includes the following Log menus: 
• Statistics 
• Measurements 
• Worst Case Waveforms 

The Log Statistics menu includes the following command buttons: 
• Yes to All 
• No to All 
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Table 68: Log Statistics menu parameters 

Option Default 
Log Statistics  
File path and name C:\TekApplications\TDSJIT3v2\log\stats.csv 
   On  
   Off Off 
   Delete  
Save Current Statistics  
File path and name C:\TekApplications\TDSJIT3v2\log\StatsSnapshot.csv 
   Save  
   Delete  
  

The Log Measurements menu includes the following command buttons: 
• Yes to All 
• No to All 

Table 69: Log Measurements Configure menu parameters 

Option Default 
Log Measurements  
Directory path C:\TekApplications\TDSJIT3v2\log\measurements 
   On  
   Off Off 
   Delete  
Save Current 
Measurements 

 

Directory path C:\TekApplications\TDSJIT3v2\log\measurementsSnapshot
   Save  
   Delete  
  

The Log Worst Case menu includes the following command buttons: 
• Yes to All 
• No to All 
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Table 70: Log Worst Case Waveforms Configure menu 
parameters 

Option Default 
Log Worst Case Waveforms  
Directory path C:\TekApplications\TDSJIT3v2\log\waveforms 
   On  
   Off Off 
   Delete  
  

Utilities 
The application includes the following Utility menus: 
• Deskew 
• Acq Timeout 
• Warnings 

The Deskew menu includes the following command buttons: 
• Perform Deskew 
• Summary 

Table 71: Deskew menu parameters 

Option Parameters Default 
Reference   
   Source Ch1, Ch2, Ch3, Ch4 Ch1 
   Mid -20 µV to 20 mV in 1 µV units 0 V 
   Hysteresis 1 µV to 30 V µin 1 µV units 30 mV 
Target   
   Source Ch1, Ch2, Ch3, Ch4 Ch2 
   Mid -20 µV to 20 mV in 1 µV units 0 V 
   Hysteresis 1 µV to 30 V µin 1 µV units 30 mV 
Use Edges Rise, Fall, Both Rise 
Deskew Range   
   Max. Value -24.9 ns to 25.0 ns in 1 ns units 1 ns 
   Min. Value -25.0 ns to 24.9 ns in 100 ps units -1 ns 
Summary Lists Source and resultant Deskew value  
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Table 72: Acq Timeout menu parameters 

Option Parameters Default 
Acquisition Timeout Auto, User Auto 
User:  
   Timeout*** 

 
30 s to 24 hours in 30 s units 

 
30 s 

* Available when the Acquisition Timeout option is set to User. 
** Application waits until  the Timeout value for a signal before stopping a Single 
or Free Run sequence with an error of failed to acquire signal. 
  

The Warnings menu includes the following command buttons: 
• View 
• Clear 

Help 
The Help menu includes the following items: 
• Wizard 
• Topics 
• About TDSJIT3 v2 
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GPIB 
You can use remote GPIB commands to communicate with the TDSJIT3 v2 
application. The application includes several example files of a GPIB program. 
Your GPIB program should comply with the following guidelines:  

The application startup must complete before sending additional GPIB 
commands to the application. You can query the variable application and it will 
return "TDSJIT3v2A" or "TDSJIT3v2E" when the application startup is 
complete. 

Recall a setup file from GPIB to select measurements and set up the application. 
The recall must be complete before sending additional GPIB commands. You can 
query the variable setup and it will return "Ready" when the recall is complete. 

The measurements cycle must complete before data is queried. You can query 
the variable SequencerState and it will return "Ready" when sequencing is 
complete. 

The resultFor and resultAcq variables must be set before querying results and the 
variable changes must be complete before the results can be read. You can query 
the variable (resultFor or resultAcq) and it will return "Busy" until the variable 
has been accepted, after which it will return the value set. If resultFor attempts to 
set "measN" when there are fewer than N measurements currently configured, it 
will return an error string specifying the number of measurements configured. 

The error variable should be checked to ensure that an error has not occurred. 
The measError and rjDjError variables return errors specific to the measurement 
selected by resultFor. 

Check and service the Event Queue frequently to avoid queue overflow.  This 
can be done using *ESR?, followed by allev? if ESR returns non-zero.  You can 
see an example of this logic in the function clear_queue(), in example program 
tdsjit3ctrl.c. 

 

Note: GPIB variables may take up to 150 msec to be updated. Therefore, any 
loop which queries a GPIB variable to see when it reverts back to its initial state 
should wait at least 150 msec before the first query. 

 CAUTION. Do not turn on GPIB headers in your program. 

 CAUTION. Commands are case and space sensitive. Your program will not 
operate correctly if you do not follow the capitalization and spacing precisely. 
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Program Example 
The program examples show how to communicate with the TDSJIT3 application 
using remote GPIB commands. The program includes the following steps:  
1. Start the TDSJIT3 application. 
2. Recognize an active application with GPIB protocol. 
3. Recall a setup to make TDSJIT3 application selections. 
4. Sequence measurements. 
5. Read measurement results. 
6. Exit the application. 

GPIB Reference Materials 
To use GPIB commands with your oscilloscope, you can refer to the following 
materials: 
• The GPIB Program Example topic for guidelines to use while designing a 

GPIB program 
• The Parameters topics for range of values, minimum units and default values 

of parameters 
• The programmer information in the online help of your oscilloscope 

Starting and Setting Up the Application Using GPIB 

Depending on your oscilloscope model, the TDSJIT3A/TDSJIT3E application 
can be started by sending the oscilloscope the following GPIB command: 
application:activate "Jitter Analysis" 
or by sending the oscilloscope the following GPIB command: 
application:activate "Jitter Analysis - Advanced" 
application:activate "Jitter Analysis - Essentials" 
Note: The name of the application in the previous string is identical to the name 
of the application from the oscilloscope Run Application list. 

The application uses the GPIB VARIABLE:VALUE command with arguments 
to execute some features. The set of GPIB commands does not include the 
variable names and variable values necessary to select and configure the 
measurements in the GPIB program. 

You must manually set up the application and oscilloscope, selecting and 
configuring the measurements that you want to use with your GPIB program, and 
save them in a setup file in the default setup folder for that module. To save a 
setup file, refer to Saving a Setup File. Use the name of the saved setup file as the 
value for the "recallName" variable in your GPIB program. 
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Variable:Value Command 
The VARIABLE:VALUE TDS command accepts string arguments for a control 
or data variable and a value to which to set the argument.  

Syntax 

To set a variable to a value: 
VARIABLE:VALUE "<variable name>","<variable value>" 
Note: The arguments <variable name> and <variable value> are required in the 
order indicated. 

To query the value in a variable: 
VARIABLE:VALUE? <variable name> 

 CAUTION. Commands are case and space sensitive. Your program will not 
operate correctly if you do not follow the capitalization and spacing precisely. 
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Table 73: Variable: Value command arguments and queries part 1  

Group/name Value Function Query form returns … 
application {exit} Terminates the active 

application 
TDSJIT3v2A or TDSJIT3v2E

Sequencer 
sequencerMode {MeasureOnly, 

FreeRun, Single} 
Sets the sequencer mode; 
startup default is Single. 

Sequencer mode 

sequencerState {Stop, Sequencing} 
 

Sends the Measurement 
Sequencing or the Stop 
Sequencing command 

{Most recent setting, Ready}; 
Ready indicates that the 
value was processed 
  

reset {Results} Clears the active 
measurement results and 
plots 

{Most recent setting, Ready}; 
Ready indicates that the 
value was processed 

Save/Recall 
setup* {Default, Recall} Performs the 

Save/Recall/Default setup 
action 

{Most recent setting, Ready} 
Most recent setting if value 
(action) is being processed; 
Ready indicates value has 
been processed 

recallName† <filespec>‡ filename 
without extension 

Sets the Recall setup file 
name; filename extension 
.ini is optional and startup 
default is setup.ini  

Current <filespec>‡ filename 
without extension 

recallDirectory Query only Reports the location of  the 
Recall directory displayed 
in the File>Recall… list; 
startup default is 
\TekApplications\TDSJIT3\
setup  

Current <pathspec>§ 
directory value 

Source Scaling 
sourceScaleAutoset {Vert, Horiz, All} Starts autoset sequence 

using the preference in 
sourceScaleOptimize 

{Most recent setting, 
Ready}; Ready indicates 
value has been processed 

sourceScaleOptimize {Count, Resolution} Selects Horizontal Autoset 
preference: High Edge 
Count or better Edge 
Resolution (default) 

Current value 

* Query may return an error code if command fails. 
† If the file name is not valid (contains characters other than letters, digits, and dots), then the application 
resets to the last set valid file name. Query to these commands return the file name without extension. 
‡ <filespec> is a string of from 1 to 40 characters that are valid in the Windows file system standards. 
§ <pathspec> is a Path string of from 1 to 40 characters that are valid for pathnames according to 
Windows file system standards.  In Query mode, the middle characters of strings longer than 40 
characters will be replaced with “…” to bring the string length to 40. 
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Table 74: Variable: Value command arguments and queries part 2 

 

Group/name Value Function Query form returns … 
Source ref levels 
refLevelSelect {C1, C2, C3, C4, 

R1, R2, R3, R4, 
M1, M2, M3, M4} 

Selects the source for  refLevel 
to Autoset 

Current value 

refLevelAutoset {Selected, All} Starts autoset sequence;  
Selected autosets source 
specified by refLevelSelect and 
All operates on all active 
sources 

{Most recent setting, Ready}; 
Ready indicates that the 
value was processed 

Logging Results 
logCurrentStats† {Now} Saves current acquisition and 

all acquisition statistics to the 
Save Current Statistics log file

Returns {Most recent 
setting, Ready} 
Ready indicates value has 
been processed 

logCurrentStatsDe
stination‡ 

<filespec>§ 
filename without 
extension 

Sets the Save Current 
Statistics file name, displayed 
in the Log> Statistics menu; 
filename extension .csv is 
optional; startup default is 
statsSnapshot.csv 

Current <filespec>§ file 
name without extension 

logCurrentStatsDir
ectory 

Query only Reports the location of Save 
Current Statistics directory, 
displayed in the Log> Statistics 
menu; startup default is 
\TekApplications\TDSJIT3\ log 

Current <pathspec># 
directory value 

logStatsDestination
‡ 

<filespec>§ 
filename without 
extension 

Sets the Log Statistics file 
name, displayed in the Log> 
Statistics menu; filename 
extension .csv is optional; 
startup default is stats.csv 

Current <filespec>§ file 
name without extension 

† Query may return an error code if command fails. 
‡ If the file name is not valid (contains characters other than letters, digits, and dots), then the application 
resets to the last set valid file name. Query to these commands return the file name without extension. 
§ <filespec> is a string of from 1 to 40 characters that are valid in the Microsoft Windows file system 
standards. 
# <pathspec> is a Path string of from 1 to 40 characters that are valid for pathnames according to 
Windows file system standards.  In Query mode, the middle characters of strings longer than 40 
characters will be replaced with “…” to bring the string length to 40. 
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Table 75: Variable:Value command arguments and queries part 3 

Group/name Value Function Query form returns … 
Logging Results 
logStatsDirectory Query only Reports the location of Log 

Statistics directory, displayed in 
the Log> Statistics menu; startup 
default is 
\TekApplications\TDSJIT3\ log 

Current <pathspec>* 
directory value 

logStatsState {On, Off} Sets the state of Log Statistics; 
when On, the Log Statistics file 
is amended with statistics from 
the current acquisition and all 
acquisitions after each sequence

Current value 

logCurrentMeasurements† {Now} Saves Current Measurements 
into associated Log>  
Measurements> File Names 

{Most recent setting, 
Ready} 
Ready indicates value 
has been processed. 

logCurrentMeasurementsDi
rectory 

Query only Reports the location of Save 
Current Measurements 
directory, displayed in the Log>  
Measurements> Config menu;  
startup default is 
\TekApplications\TDSJIT3\ 
measurementsSnapshot 

Current <pathspec>‡ 
directory value 

logMeasurementsDirectory Query only Reports the location of Log 
Measurements directory, 
displayed in the Log>  
Measurements> Config menu;  
startup default is 
\TekApplications\TDSJIT3\ 
measurements 

Current <pathspec>‡ 
directory value 

logMeasurementsState {On, Off} Sets the state of Log 
Measurements: when On, the 
measurements from the current 
acquisition are saved into 
associated Log> 
Measurements>File Names 

Current value 

* <pathspec> is a Path string of from 1 to 40 characters that are valid for pathnames according to 
Windows file system standards.  In Query mode, the middle characters of strings longer than 40 
characters will be replaced with “…” to bring the string length to 40. 
† Query may return an error code if command fails. 
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Table 76: Variable:Value command arguments and queries part 4 

Group/name Value Function Query form returns … 
Logging Results 
logWorstcaseDirectory Query only Reports the location of Log 

Worst Case Waveforms 
directory, which is displayed in 
the GUI’s Log> Worst Case 
Waveforms>Config Panel; 
startup default is 
\TekApplications\TDSJIT3\ 
waveforms 

Current <pathspec>* 
directory value 

logWorstcaseState {On, Off} Sets the state of Log Worst 
Case Waveforms: when On, 
the worst case waveforms are 
saved (when they occur) into 
associated Log> 
Measurements>File Names 

Current value 

Result variables 
resultFor {Meas1, Meas2, 

Meas3, Meas4, 
Meas5, Meas6} 

Specifies the measurement 
number for which results are 
requested by location in the 
results table; you can query the 
"measurement"   variable to get 
a keycode for the name of the 
measurement  and input source

After set to a Measn 
value, query returns 
"Busy" until results are 
refreshed, then value set 
back to entered value 
Measn; see the About the 
GPIB Program and 
Guidelines topic  

resultAcq {Current, All} Specifies the measurement 
result group as the most recent 
acquired (Current) or as an 
accumulation of all the 
measurements (All) 

After set to Current or All, 
query returns "Busy" until 
results are refreshed, 
then value set back to 
entered value  

TIE RjDj/BER (Applies to the measurement selected by the resultFor command) 
rjDjBER {On, Off} Forces the RjDj BER results to 

be updated. 
After set to "On," query 
returns "Busy" until RjDj 
results are refreshed, 
then set back to "On" 

rjDjBERTarget {range: 2…18, 
by 1}  

Sets the exponent component 
of the BER (i.e., 10-?) 

After set to a new value 
query returns "Busy" until 
RjDj results are refreshed 
then set back to the new 
value 

* <pathspec> is a Path string of from 1 to 40 characters that are valid for pathnames according to 
Windows file system standards.  In Query mode, the middle characters of strings longer than 40 
characters will be replaced with “…” to bring the string length to 40. 
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Table 77: Variable:Value command arguments and queries part 5 

Group/name Value Function Query form returns … 
Plot Export 
plotSelect {range: 1..4} Sets the plot window to 

which a subsequent plot 
export command applies 

Current value 

plotSpec Query only Reports the plot type, 
measurement, and 
source(s) for the plot 
defined by plotSelect 

“key#,source(s),type”*, for 
example “Cycle 
TrendJavaplot1CP1R1" 

plotExport {Data, Image, Ref} Saves the plot as defined 
by plotSelect in the 
specified format  

{Ready, Plot Export Error} 
Ready indicates value has 
been processed, otherwise, 
check the “error” variable 
for the error. 

plotImageDir <pathspec>† Sets the directory to which 
a plot image will be saved. 

Current <pathspec>† 

directory value 
plotImageDest <filespec>‡, where 

the extension must 
be {png, jpg, bmp} 

Sets the filename under 
which a plot image will be 
saved; default file name is 
aPlotImage.png. If file 
extension is not supplied, 
then file will be a .png 

Current <filespec>‡ file 
name with extension 

plotDataDir <pathspec>† Sets the directory to which 
plot data will be saved 

Current <pathspec>† 

directory value 
plotDataDest <filespec>‡, where 

the extension must 
be {txt, csv, mat} 

Sets the filename under 
which plot data will be 
saved; default file name is 
aPlotData.txt. If file 
extension is not supplied, 
then file will .txt. 

Current <filespec>‡ file 
name with extension 

plotRefDest {Ref1, Ref2, Ref3, 
Ref4} 

Sets the scope reference 
channel to which a 
subsequent plot waveform 
export command applies 

Current value 

* key is an abbreviation for the selected measurement shown in the Measurement Names and Key topic.   
# is an integer that distinguishes between multiple measurements of the same type.   
source(s) is an abbreviation for the source or sources associated with the measurement shown in the 
Source Names and Key topic.  
type is an abbreviation for the plot format shown in the Plot Names and Key topic. For example, 
“CP1,Ch4,HS” identifies a Histogram plot of the first Clock Period measurement on Channel4, and 
“SU2,Ch3,M1,TT” identifies a Time Trend plot of the second Setup measurement from Channel3 to Math1. 
† <pathspec> is a Path string of from 1 to 40 characters that are valid for pathnames according to 
Windows file system standards.  In Query mode, the middle characters of strings longer than 40 
characters will be replaced with “…” to bring the string length to 40. 
‡ <filespec> is a string of from 1 to 40 characters that are valid for filename strings according to Windows 
file system standards. 
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Measurements Results Queries 

 CAUTION: After sending the resultFor and the resultAcq commands, be 
sure to wait until the command has been accepted prior to doing measurement 
queries. To do this, wait at least 150 milliseconds and then query the value of 
resultFor or resultAcq again. The variable will return Busy until it is accepted, 
after which it will return the value that you sent. If you send a resultFor value 
that is invalid, the value returned following the Busy will be an error string. 

You need to use the VARIABLE:VALUE? form to enter measurement results 
queries in your GPIB program. Before you can do this, you must first set the 
measurement with the resultFor command. You can select the Current or all 
acquisition statistics with the resultAcq command. 

The Variable:Value JITTER3 Command Arguments and Queries tables list the 
measurement results queries for the measurement selected in the resultFor and 
the resultAcq variables: 
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Table 78: Measurement results queries 

 
Variable name 

Return value for measurement specified by  
resultFor and resultAcq 

measurement “key,source(s)” pair.  The key as an abbreviation for the 
selected measurement (e.g., “CP” for Clock Period) followed 
by an integer; see the Measurement Names and Key topic for 
a complete list of measurement abbreviations   
Source(s) is an abbreviation for the source or sources 
associated with the measurement (e.g., “Ch1” for Channel 1 or 
“Ch1Ch2” for a measurement that requires both Channel 1 
and Channel 2; see the Source Names and Key topic 

Statistical Results Basic statistics applicable for all measurements 
measUnits Units string for the measurement (e.g., “s” for seconds for 

Period) 
max Maximum measurement value 
maxPosDev Magnitude of the largest positive change of the measurement 
maxNegDev Magnitude of the largest negative change of the measurement
mean Mean value of the result 
min Minimum measurement value 
pkpk Peak-to-peak measurement value (max – min) 
population Population (number of) measurements used to calculate the 

current statistics 
stdDev Standard deviation measurement set 
RjDj Results Applies  for TIE type measurements only.  For non-TIE 

measurements, an empty string is returned.  For TIE 
measurements with RjDj turned off, a null string is returned 

dataDependent Data dependent jitter component of the TIE Jitter 
dutyCycle Duty cycle jitter component of the TIE Jitter 
deterministic Determinstic jitter component of the TIE Jitter 
periodic Periodic jitter component of the TIE Jitter 
random Estimated random jitter component of the TIE Jitter 
totalJitter Estimated total jitter component at the designated BER of the 

TIE Jitter 
eyeOpening estimated eye opening at the designated BER of the TIE Jitter 
equivDeterministic Equivalent deterministic jitter component of the TIE Jitter 
equivRandom Equivalent estimated random jitter component of the TIE Jitter 
equivTotalJitter Equivalent estimated total jitter component at the designated 

BER of the TIE Jitter 
Messages String that returns if the TDSJIT3 application has problems; 

refer to the GPIB Commands Error Codes topic 
error General error 
measError* Measurement specific error 
rjDjError* RjDj analysis related error 
warning Warning, if any, from the most recent measurement 
* Returns an error string in the form of "1:*, 2:*, 3:*, 4:*, 5:*, 6:* " where the * will be 
"None" or an error number, such as E801. For example, "1 :* " represents the first 
measurement in the active measurements table. For non-active measurements and for 
active measurements without error status, the application returns "None." Otherwise, 
the application returns the error number as listed in the GPIB Error Codes topic.  
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Table 79: Measurement names and key 

Measurement Key Measurement Key 
Clock  Clock-Data  
   Period CP    Setup SU 
   Frequency CF    Hold HOLD 
   TIE TIE    Clock-Out TCO 
   PLL TIE CPLL Clock-Data-TIE CDJ 
   Cycle-Cycle CCP General  
   N-Cycle NCP    Positive Width PW 
   Positive Cy-Cy Duty PCCD    Negative Width NW 
   Negative Cy-Cy Duty NCCD    Rise Time RISE 
   Positive Duty Cycle PDC    Fall Time FALL 
   Negative Duty Cycle NDC    High Time HIGH 
Data     Low Time LOW 
   Period DP    Skew SKEW 
   Frequency DF    Crossover Voltage CRVT 
   TIE DTIE   
   PLL TIE DPLL   
  

Table 80: Source names and key 

Source Key Source Key Source Key 
Channel1 Ch1 Ref1 R1 Math1 M1 
Channel2 Ch2 Ref2 R2 Math2 M2 
Channel3 Ch3 Ref3 R3 Math3 M3 
Channel4 Ch4 Ref4 R4 Math4 M4 

  

Table 81: Plot names and key 

Plot type Key Plot type Key 
Histogram HS Bathtub BT 
Time Trend TT Transfer Function TF 
Cycle Trend CT Phase Noise PN 
Spectrum SP   
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Table 82: Error codes 

Code Description 
E014 Unable to import waveform; stopping sequencing 
E101 Failed to acquire signal; timed out waiting for trigger 
E102 Unable to acquire waveform; sequencing halted 
E103 Record length changed during sequencing 
E104 Not enough edges in qualified portion of waveform 
E105 Unable to turn on sources 
E106 Not enough edges for Deskew to work 
E107 Deskew only works on live channels 
E108 No measurements selected 
E109 GPIB timeout occurred 
E110 GPIB error occurred 
E151 Level Too High for <Vref ID> -- Autoset Ref Level 
E152 Level Too Low for <Vref ID> 
E153 Hysteresis Too Wide for the signal for <Vref ID> 
E154 Signal never above Vref Mid + hysteresis / 2 for <Vref ID> 
E155 Signal never below Vref Mid - hysteresis / 2 for <Vref ID> 
E201 The number of edges is not sufficient for a measurement 
E202 Upper range should be greater than lower range 
E203 Unable to estimate baud rate; check configuration 
E204 PLL bandwidth is too high; maximum is baud rate / 10 
E221 Unable to read pattern file 
E222 Pattern file has too few bits 
E223 Pattern file has too many bits 
E301 Conflict detected in resource usage 
E401 No signal to work on; check for a valid signal 
E402 No source selected 
E403 No active sources 
E404 Error setting reference levels 
W405 Source amplitude is extremely low 
E406 Autoset failed 
E407 Vertical autoset failed 
E408 Horizontal autoset failed 
W409 Waveform is clipped 
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Code Description 
E901 There are currently no results to snapshot. Please perform a 

measurement first 
E903 Select at least one measurement from the table before choosing 

Save 
W904 Statistics logging turned off. Statistics for >= 1000000 

acquisitions logged to file 
W905 Measurement logging turned off. >= 1000000 measurements 

logged to file(s). 
W1001 Maximum population limit reached: 
W1111 Jitter Transfer Plot requires two measurements 
W1112 No measurements are enabled, unable to create plot 
E1113 Error exporting plot data 
E1114 Error exporting plot image 
E1115 Error exporting plot to Ref wfm 
E1116 Error creating directory 
E1201 Filter cut-off frequency is higher than Nyquist frequency. Filter 

settings ignored 
E1202 Result has 0 population since transient duration of filter is set 

longer than waveform time span. Either acquire a longer duration 
waveform, increase your filter bandwidth, or reduce the filter 
settling time 

W1203 Settling time of filter is small relative to 1/bandwidth. Initial 
transient may not be completely removed from measurement 
results 

W1301 Clock recovery from data pattern disagrees with nominal data 
rate. Clock recovery from data pattern is used 

W1302 Clock recovery result implies unstable data rate. Check nominal 
data rate and other configurations 

W1303 Clock recovery result implies unstable data rate. Check 
configurations 
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